Si verifica un ritardo di lungo periodo di tempo, quando ci si ricollega una connessione IPSec da un computer basato su Windows Server 2003 a un nodo cluster dopo un failover del cluster

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Sintomi

Prendere in considerazione i seguenti scenari.

Scenario 1

  • Si dispone di un cluster basato su Windows Server che utilizza Windows Network Load Balancing, Clustering di Failover, un sistema di bilanciamento del carico hardware o un prodotto di cluster hardware.
  • Internet Protocol Security (Ipsec) (IPsec) non è stabilire la connessione all'indirizzo IP virtuale di cluster da un computer client basato su Windows Server 2003.
  • Errore di un nodo del cluster, è necessario riavviare manualmente il nodo, o si verifica un errore del nodo in modo che un altro nodo rileva la connessione del client.

Scenario 2

  • Un sistema operativo basato su Windows Server 2003 non cluster verrà riavviato in meno di 6 minuti (ad esempio una macchina virtuale) o viene riavviato automaticamente entro 6 minuti dopo che si verifica un errore irreversibile.
  • Per stabilire una connessione di IP security (IPsec) per il sistema operativo da un altro computer client basato su Windows Server 2003.

In questi casi, si verifica un ritardo di lungo periodo di tempo (circa due o tre minuti) quando il computer client ristabilisce la connessione IPsec al cluster in scenario 1 e il computer non cluster nello scenario 2.

Cause

Questo problema si verifica perché IPsec non è progettato in modo ottimale per un ambiente di cluster di failover. Un valore di timeout di grandi dimensioni è associato l'associazione di protezione IPSec (SA) corrente. Cerchiamo inoltre di una negoziazione aggiuntiva con un time-out.

Risoluzione

Dopo aver installato il pacchetto di hotfix, è necessario creare le seguenti sottochiavi del Registro di due sistema sul computer client basato su Windows Server 2003:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IPSec\NlbsIdleTime


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent\Oakley\NlbsIdle


A tale scopo, attenersi alla procedura descritta nella sezione informazioni del Registro di sistema.

Informazioni sull'aggiornamento rapido

È disponibile un hotfix supportato. Tuttavia, questo hotfix è destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico.

Se l'aggiornamento rapido è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di assistenza tecnica e supporto tecnico per ottenere l'hotfix.

NotaSe si verificano ulteriori problemi o se è richiesta la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto standard verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
NotaIl modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non è disponibile la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario eseguire Windows Server 2003 Service Pack 2 (SP2).

Informazioni del Registro di sistema

ImportanteQuesta sezione, metodo o attività contiene viene illustrato come modificare il Registro di sistema. Tuttavia, può causare seri problemi se si modifica il Registro di sistema in modo non corretto. Pertanto, assicurarsi di seguire attentamente i passaggi. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Quindi, è possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
articolo 322756Come eseguire il backup e ripristinare il Registro di sistema in Windows
Dopo aver installato il pacchetto di hotfix, è necessario creare le seguenti sottochiavi del Registro di due sistema sul computer client basato su Windows Server 2003:
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IPSec\NlbsIdleTime
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent\Oakley\NlbsIdle
A tale scopo, attenersi alla seguente procedura:
  1. Fare clic suAvviare, fare clic suEseguire, tipoRegedit, quindi fare clic suOK.
  2. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IPSec
  3. NelModificadal menuNuovo, quindi fare clic suValore DWORD.
  4. TipoNlbsIdleTime, quindi premere INVIO.
  5. Pulsante destro del mouseNlbsIdleTime, quindi fare clic suModificare.
  6. NelDati valoredigitare5, quindi fare clic suOK.

    Nota
    L'intervallo di valori è da 5 a 60.
  7. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent\Oakley
  8. NelModificadal menuNuovo, quindi fare clic suValore DWORD.
  9. TipoNlbsIdle, quindi premere INVIO.
  10. Pulsante destro del mouseNlbsIdle, quindi fare clic suModificare.
  11. NelDati valoredigitare1, quindi fare clic suOK.
  12. Uscire dall'Editor del Registro di sistema.
NotaÈ necessario assicurarsi che le seguenti sottochiavi del Registro di sistema presenti su tutti i nodi del cluster basato su Windows Server e che il valore della sottochiave del Registro di sistema è 1, quando si crea una connessione IPSec in un nodo del cluster. In questo modo i client identificare la connessione a una risorsa cluster.

Per Windows Server 2003-basedcnodo di superficie:

Percorso: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent\Oakley\

Nome: nlbsflags

Tipo: REG_DWORD

Valore: 1

Per Windows Server 2008-base oWindows Server 2008 R2-in basecnodo di superficie:

Percorso: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IKEEXT\Parameters\

Nome: nlbsflags

Tipo: REG_DWORD

Valore: 1

Richiesta di riavvio

Dopo aver applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

Informazioni sui file

La versione inglese (Stati Uniti) di questo aggiornamento rapido consente di installare i file con gli attributi elencati nelle tabelle seguenti. Le date e le ore dei file elencate UTC (Coordinated Universal Time). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale. Inoltre, le date e gli orari cambiano quando si eseguono determinate operazioni sui file.
Note informative relative al file Windows Server 2003
  • Oltre ai file elencati in queste tabelle, questo aggiornamento rapido viene installato anche un file di catalogo di protezione associato (KBnumero. cat) che viene apposta una firma digitale Microsoft.
Per tutte le versioni x86 di Windows Server 2003
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
. Sys5.2.3790.47988294412-Nov-201014. 57x86SERVICE PACK 2SP2QFE
Oakley. dll5.2.3790.4798352,76815-Nov-201008: 55x86SPSP2QFE
Per tutte le versioni basate su x64 di Windows Server 2003
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
. Sys5.2.3790.4798157,18415-Nov-201006: 41x64SERVICE PACK 2SP2QFE
Oakley. dll5.2.3790.4798394,75215-Nov-201006: 41x64SPSP2QFE
Woakley.dll5.2.3790.4798352,76815-Nov-201006: 41x86SERVICE PACK 2SP2QFE\WOW
Per tutti basati su IA-64 versioni supportate di Windows Server 2003
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
. Sys5.2.3790.4798259,58415-Nov-201006: 41IA-64SERVICE PACK 2SP2QFE
Oakley. dll5.2.3790.4798550,40015-Nov-201006: 41IA-64SPSP2QFE
Woakley.dll5.2.3790.4798352,76815-Nov-201006: 41x86SERVICE PACK 2SP2QFE\WOW

Status

Microsoft ha confermato che questo è un problema con i prodotti elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
306677Failover IPsec può richiedere fino a sei minuti in Windows 2000

Proprietà

Identificativo articolo: 980915 - Ultima modifica: lunedì 21 marzo 2011 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003 Service Pack 2 alle seguenti piattaforme
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise x64 Edition
Chiavi: 
kbqfe kbfix kbhotfixserver kbsurveynew kbexpertiseinter kbmt KB980915 KbMtit
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