FIX: A SQL Server assertion is logged in the SQL Server Errorlog file when you restart the SQL Server service in SQL Server 2005

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Article ID: 981273 - View products that this article applies to.
Microsoft distributes Microsoft SQL Server 2005 fixes as one downloadable file. Because the fixes are cumulative, each new release contains all the hotfixes and all the security fixes that were included with the previous SQL Server 2005 fix release.
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SYMPTOMS

In Microsoft SQL Server 2005, when you restart the SQL Server service, error messages that resemble the following are logged in the SQL Server Errorlog file.


Error message 1

SQL Server Assertion: File: <"logmgr.cpp">, line=5565 Failed Assertion = '!(minLSN.m_fSeqNo < lfcb->lfcb_fSeqNo)'. This error may be timing-related. If the error persists after rerunning the statement, use DBCC CHECKDB to check the database for structural integrity, or restart the server to ensure in-memory data structures are not corrupted.

Error message 2

Process 30:0:0 (0x1dbc) Worker 0x00000000071561C0 appears to be non-yielding on Scheduler 4. Thread creation time: <time>. Approx Thread CPU Used: kernel 0 ms, user 0 ms. Process Utilization 1%. System Idle 95%. Interval: 75000 ms.

CAUSE

This problem occurs because a SQL Server assertion occurs under a spinlock when you restart the SQL Server service.

RESOLUTION

Cumulative update information

The fix for this issue was first released in Cumulative Update 10. For more information about how to obtain this cumulative update package for SQL Server 2005, click the following article number to view the article in the Microsoft Knowledge Base:
983329 Cumulative update package 10 for SQL Server 2005 Service Pack 3
Note Because the builds are cumulative, each new fix release contains all the hotfixes and all the security fixes that were included with the previous SQL Server 2005 fix release. We recommend that you consider applying the most recent fix release that contains this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
960598 The SQL Server 2005 builds that were released after SQL Server 2005 Service Pack 3 was released

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

A spinlock is a lock where the thread waits in a loop (Spin) that repeatedly checks until the lock becomes available. When the thread remains active but does not perform a useful task, such a lock is a kind of busy waiting. When SQL Server uses a spinlock, the spinlock is typically held until it is explicitly released. 

REFERENCES

For more information about the Incremental Servicing Model for SQL Server, click the following article number to view the article in the Microsoft Knowledge Base:
935897 An Incremental Servicing Model is available from the SQL Server team to deliver hotfixes for reported problems


For more information about the naming schema for SQL Server updates, click the following article number to view the article in the Microsoft Knowledge Base:
822499 New naming schema for Microsoft SQL Server software update packages


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 981273 - Last Review: June 23, 2010 - Revision: 2.0
APPLIES TO
  • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Developer Edition
  • Microsoft SQL Server 2005 Enterprise Edition
  • Microsoft SQL Server 2005 Enterprise X64 Edition
  • Microsoft SQL Server 2005 Workgroup Edition
Keywords: 
kbsurveynew kbqfe kbfix kbexpertiseadvanced KB981273

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