Es posible que un recurso de disco físico no se conecte en un nodo de clúster.

Este artículo ayuda a resolver un problema por el que un recurso de disco físico no está en línea en un nodo de clúster.

Se aplica a: Windows Server 2012 R2
Número de KB original: 981475

Síntomas

En un nodo de clúster que ejecuta Windows Server, un recurso de disco físico puede entrar en el estado Error al intentar mover un grupo que contiene el recurso de disco físico. Si reinicia el nodo de clúster que tiene el recurso de disco físico que no se ha conectado, el problema se resuelve temporalmente.

Cuando se produce este problema, las siguientes entradas se registran en el registro de clúster para el recurso de disco físico que entró en el estado de error :

0000020cc.000014d0::<DateTime> ERR Disco de disco <físico Q:>:
DiskspCheckPath: GetFileAttrs(Q:) devuelve el estado 87.
0000020cc.000014d0::<DateTime> WARN Disco de disco <físico Q:>:
DiskspCheckDriveLetter: comprobar el nombre de la unidad (Q:) devuelve 87

Además, los siguientes eventos se registran en el registro de eventos del sistema:

Tipo de evento: Error
Origen del evento: ClusSvc
Categoría de eventos: Recurso de disco físico
Identificador de evento: 1066
Fecha: <fecha>
Hora: <hora>
Usuario: N/A
Equipo: <nombre del nodo>
Descripción: el recurso de disco del clúster "Disk Q:" está dañado. Ejecute "ChkDsk /F" para reparar problemas. El nombre del volumen de este recurso es "<\?\Volume{4323d41e-1379-11dd-9538-001e0b20dfe6}>". Si está disponible, la salida de ChkDsk estará en el archivo "C:\WINDOWS\Cluster\ChkDsk_Disk2_SigB05E593B.log". ChkDsk puede escribir información en el registro de eventos de la aplicación con el identificador de evento 26180.

Tipo de evento: Error
Origen del evento: ClusSvc
Categoría de eventos: Recurso de disco físico
Identificador de evento: 1035
Fecha: <fecha>
Hora: <hora>
Usuario: N/A
Equipo: <nombre del nodo>
Descripción: no se pudo montar el recurso de disco del clúster "Disk Q:".

De forma similar, en un nodo de clúster de Windows Server, es posible que vea que las siguientes entradas se registran en el registro de clúster:

000000db0.00000868::<DateTime> WARN [RES] Disco de clúster de disco <físico 1>: OnlineThread: no se pudo obtener el guid de volumen para el dispositivo \?\GLOBALROOT\Device\Harddisk15\Partition1. Error 3
000000db0.00000868::<DateTime> WARN [RES] Disco de clúster de disco <físico 1>: OnlineThread: Failed to set volguid ?? \Volume{3cb36133-0d0b-11df-afcf-005056ab58b9}. Error: 183.
000000db0.00000868::<DateTime> INFO [RES] Disco de clúster de disco <físico 1>: VolumeIsNtfs: Volume \?\GLOBALROOT\Device\Harddisk15\Partition1\ tiene el tipo FS NTFS

Causa

Se sabe que este problema se produce cuando se instala, actualiza o reconfigura el software antivirus que no es compatible con el clúster. Por ejemplo, se sabe que este problema se produce después de instalar o migrar a Symantec Endpoint Protection 11.0 Release Update 5 (RU5) en los nodos del clúster.

Solución

Para resolver este problema, siga estos pasos:

  1. Compruebe que este problema se debe a Symantec Endpoint Protection (SEP) 11.0 Release Update 5 (RU5). Para ello, ejecute la utilidad Handle.exe inmediatamente después de que se produzca el problema en el nodo del clúster donde el recurso de disco físico no se ha conectado.

    En un símbolo del sistema con privilegios elevados, escriba el siguiente comando y presione ENTRAR: Handle.exe -a -u drive_letter.

    Nota:

    El marcador de posición drive_letter es la designación de unidad de la unidad de clúster que no se ha conectado.

    Por ejemplo, suponga que la designación de unidad para la unidad de clúster que no se ha conectado es la unidad Q. Para ejecutar la utilidad Handle.exe en este escenario, escriba el siguiente comando y presione ENTRAR: Handle.exe -a -u Q:.

    El problema lo produce la aplicación Symantec si recibe el siguiente mensaje que identifica el proceso de Smc.exe como el proceso que posee el identificador:

    Control de la versión 3.42
    Copyright (C) 1997-2008 Mark Russinovich
    Sysinternals : www.sysinternals.com

    Smc.exe pid: 856 NT AUTHORITY\SYSTEM 66C: Q:

  2. Si el problema se debe a la aplicación Symantec, póngase en contacto con Symantec para obtener symantec Endpoint Protection 11 Release Update 6 (RU6), que se publicó para resolver este problema.

Más información

Para obtener más información sobre la utilidad de Handle.exe, consulte Control de la versión 4.22.

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