Une ressource de disque physique peut ne pas être mise en ligne sur un nœud de cluster

Cet article vous aide à résoudre un problème où une ressource de disque physique n’est pas mise en ligne sur un nœud de cluster.

S’applique à : Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 981475

Symptômes

Sur un nœud de cluster exécutant Windows Server, une ressource de disque physique peut passer à l’état Échec lorsque vous essayez de déplacer un groupe qui contient la ressource de disque physique. Si vous redémarrez le nœud de cluster qui a la ressource de disque physique qui n’a pas été mise en ligne, le problème est temporairement résolu.

Lorsque ce problème se produit, les entrées suivantes sont enregistrées dans le journal du cluster pour la ressource de disque physique qui est entrée dans l’état d’échec :

000020cc.000014d0 ::<DateTime> ERR Physical Disk <Disk Disk Q :>:
DiskspCheckPath : GetFileAttrs(Q :) a retourné status de 87.
000020cc.000014d0 ::<DateTime> WARN Physical Disk <Disk Q :>:
DiskspCheckDriveLetter : la vérification du nom du lecteur (Q :) renvoie 87

En outre, les événements suivants sont enregistrés dans le journal des événements système :

Type d'événement : Erreur
Source de l’événement : ClusSvc
Catégorie d’événement : Ressource de disque physique
ID d’événement : 1066
Date : <date>
Heure : <heure>
Utilisateur : N/A
Ordinateur : <nom du nœud>
Description : la ressource de disque de cluster « Disk Q : » est endommagée. Exécutez « ChkDsk /F » pour réparer les problèmes. Le nom du volume pour cette ressource est «< \ ?\Volume{4323d41e-1379-11dd-9538-001e0b20dfe6}> ». Si elle est disponible, la sortie ChkDsk se trouve dans le fichier « C :\WINDOWS\Cluster\ChkDsk_Disk2_SigB05E593B.log ». ChkDsk peut écrire des informations dans le journal des événements de l’application avec l’ID d’événement 26180.

Type d'événement : Erreur
Source de l’événement : ClusSvc
Catégorie d’événement : Ressource de disque physique
ID d’événement : 1035
Date : <date>
Heure : <heure>
Utilisateur : N/A
Ordinateur : <nom du nœud>
Description : La ressource de disque de cluster « Disk Q : » n’a pas pu être montée.

De même, sur un nœud de cluster Windows Server, vous pouvez voir que les entrées suivantes sont enregistrées dans le journal du cluster :

00000db0.00000868 ::<DateTime> WARN [RES] Disque de cluster de disque <physique 1> : OnlineThread : Échec de l’obtention du GUID de volume pour l’appareil \ ?\GLOBALROOT\Device\Harddisk15\Partition1. Erreur 3
00000db0.00000868 ::<DateTime> WARN [RES] Disque de cluster de disque <physique 1> : OnlineThread : Échec de la définition de volguid ?? \Volume{3cb36133-0d0b-11df-afcf-005056ab58b9}. Erreur : 183.
00000db0.00000868 ::<DateTime> INFO [RES] Disque de cluster de disque <physique 1> : VolumeIsNtfs : Volume \ ?\GLOBALROOT\Device\Harddisk15\Partition1\ has FS type NTFS

Cause

Ce problème est connu pour se produire quand un logiciel antivirus qui ne prend pas en charge les clusters est installé, mis à niveau ou reconfiguré. Par exemple, ce problème est connu pour se produire après l’installation ou la migration vers Symantec Endpoint Protection 11.0 Release Update 5 (RU5) sur les nœuds de cluster.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Vérifiez que ce problème est dû à Symantec Endpoint Protection (SEP) 11.0 Release Update 5 (RU5). Pour ce faire, exécutez l’utilitaire Handle.exe immédiatement après que le problème s’est produit sur le nœud de cluster où la ressource de disque physique n’a pas été mise en ligne.

    À l’invite de commandes avec élévation de privilèges, tapez la commande suivante, puis appuyez sur Entrée : Handle.exe -a -u drive_letter.

    Remarque

    L’espace réservé drive_letter est la désignation du lecteur de cluster qui n’a pas été mis en ligne.

    Par exemple, supposons que la désignation du lecteur de cluster qui n’a pas été mis en ligne est le lecteur Q. Pour exécuter l’utilitaire Handle.exe dans ce scénario, tapez la commande suivante, puis appuyez sur Entrée : Handle.exe -a -u Q:.

    Le problème est dû à l’application Symantec si vous recevez le message suivant qui identifie le processus Smc.exe en tant que processus propriétaire du handle :

    Gérer v3.42
    Copyright (C) 1997-2008 Mark Russinovich
    Sysinternals - www.sysinternals.com

    Smc.exe pid: 856 NT AUTHORITY\SYSTEM 66C: Q:

  2. Si le problème est dû à l’application Symantec, contactez Symantec pour obtenir Symantec Endpoint Protection 11 Version Update 6 (RU6), qui a été publiée pour résoudre ce problème.

Plus d’informations

Pour plus d’informations sur l’utilitaire Handle.exe, consultez Gérer la version 4.22.

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