Een fysieke schijfresource is mogelijk niet online op een clusterknooppunt

Dit artikel helpt bij het oplossen van een probleem waarbij een fysieke schijfresource niet online komt op een clusterknooppunt.

Van toepassing op: Windows Server 2012 R2
Origineel KB-nummer: 981475

Symptomen

Op een clusterknooppunt waarop Windows Server wordt uitgevoerd, kan een fysieke schijfresource de status Mislukt krijgen wanneer u probeert een groep te verplaatsen die de fysieke schijfresource bevat. Als u het clusterknooppunt met de fysieke schijfresource die niet online is gekomen, opnieuw opstart, wordt het probleem tijdelijk opgelost.

Wanneer dit probleem zich voordoet, worden de volgende vermeldingen vastgelegd in het clusterlogboek voor de fysieke schijfresource die de status Mislukt heeft:

000020cc.000014d0::<DateTime> ERR Physical Disk <Disk Disk Q:>:
DiskspCheckPath: GetFileAttrs(Q:) retourneert de status 87.
000020cc.000014d0::<DateTime> WARN Physical Disk <Disk Q:>:
DiskspCheckDriveLetter: Het controleren van de stationsnaam (Q:) retourneert 87

Daarnaast worden de volgende gebeurtenissen vastgelegd in het systeemgebeurtenislogboek:

Gebeurtenistype: Fout
Gebeurtenisbron: ClusSvc
Gebeurteniscategorie: Fysieke schijfresource
Gebeurtenis-id: 1066
Datum: <datum>
Tijd: <tijd>
Gebruiker: N.b.
Computer: <knooppuntnaam>
Beschrijving: Clusterschijfresource 'Schijf Q:' is beschadigd. Voer 'ChkDsk /F' uit om problemen te herstellen. De volumenaam voor deze resource is \<?\Volume{4323d41e-1379-11dd-9538-001e0b20dfe6}>. Indien beschikbaar, bevindt de ChkDsk-uitvoer zich in het bestand C:\WINDOWS\Cluster\ChkDsk_Disk2_SigB05E593B.log. ChkDsk kan informatie naar het toepassingsgebeurtenislogboek schrijven met gebeurtenis-id 26180.

Gebeurtenistype: Fout
Gebeurtenisbron: ClusSvc
Gebeurteniscategorie: Fysieke schijfresource
Gebeurtenis-id: 1035
Datum: <datum>
Tijd: <tijd>
Gebruiker: N.b.
Computer: <knooppuntnaam>
Beschrijving: Clusterschijfresource 'Schijf Q:' kan niet worden gekoppeld.

Op dezelfde manier ziet u op een Windows Server-clusterknooppunt de volgende vermeldingen die zijn vastgelegd in het clusterlogboek:

00000db0.00000868::<DateTime> WARN [RES] Physical Disk <Cluster Disk 1>: OnlineThread: Kan volume-guid niet ophalen voor apparaat \?\GLOBALROOT\Device\Harddisk15\Partition1. Fout 3
00000db0.00000868::<DateTime> WARN [RES] Physical Disk <Cluster Disk 1>: OnlineThread: Kan volguid niet instellen? \Volume{3cb36133-0d0b-11df-afcf-005056ab58b9}. Fout: 183.
00000db0.00000868::<DateTime> INFO [RES] Physical Disk <Cluster Disk 1>: VolumeIsNtfs: Volume \?\GLOBALROOT\Device\Harddisk15\Partition1\ heeft FS-type NTFS

Oorzaak

Dit probleem treedt op wanneer antivirussoftware die niet clusterbewust is geïnstalleerd, bijgewerkt of opnieuw wordt geconfigureerd. Het is bijvoorbeeld bekend dat dit probleem optreedt nadat u Symantec Endpoint Protection 11.0 Release Update 5 (RU5) op de clusterknooppunten hebt geïnstalleerd of gemigreerd.

Oplossing

Ga als volgt te werk om dit probleem op te lossen:

  1. Controleer of dit probleem wordt veroorzaakt door Symantec Endpoint Protection (SEP) 11.0 Release Update 5 (RU5). Voer hiervoor het hulpprogramma Handle.exe uit direct nadat het probleem is opgetreden op het clusterknooppunt waar de fysieke schijfresource niet online is gekomen.

    Typ bij een opdrachtprompt met verhoogde bevoegdheid de volgende opdracht en druk op Enter: Handle.exe -a -u drive_letter.

    Opmerking

    De tijdelijke aanduiding drive_letter is de stationsaanduiding voor het clusterstation dat niet online is gekomen.

    Stel dat de stationsaanduiding voor het clusterstation dat niet online is gekomen station Q is. Als u het hulpprogramma Handle.exe in dit scenario wilt uitvoeren, typt u de volgende opdracht en drukt u op Enter: Handle.exe -a -u Q:.

    Het probleem wordt veroorzaakt door de Symantec-toepassing als u het volgende bericht ontvangt dat het Smc.exe proces wordt geïdentificeerd als het proces dat eigenaar is van de ingang:

    Handle v3.42
    Copyright (C) 1997-2008 Mark Russinovich
    Sysinternals - www.sysinternals.com

    Smc.exe pid: 856 NT AUTHORITY\SYSTEM 66C: Q:

  2. Als het probleem wordt veroorzaakt door de Symantec-toepassing, neemt u contact op met Symantec om Symantec Endpoint Protection 11 Release Update 6 (RU6) te verkrijgen, die is uitgebracht om dit probleem op te lossen.

Meer informatie

Zie Handle v4.22 voor meer informatie over het hulpprogramma Handle.exe.

De producten van derden die in dit artikel worden vermeld, worden vervaardigd door bedrijven die onafhankelijk zijn van Microsoft. Microsoft verleent dan ook geen enkele garantie, impliciet noch anderszins, omtrent de prestaties of de betrouwbaarheid van deze producten.