Outlook stops updating the screen correctly after Outlook 2007 is running for a long period of time

Article translations Article translations
Article ID: 981579 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

After Microsoft Office Outlook 2007 is running for a long time, Outlook 2007 stops updating the screen correctly. For example, you may experience any of the symptoms described underneath:
  • Parts of the Outlook window are now blank.
  • Parts of the Outlook window are now transparent.
  • Views are draw incorrectly or incompletely.
  • Icons may disappear.
  • Toolbars may disappear.

CAUSE

This issue occurs because a leak occurs in Graphics Device Interface (GDI) objects when you run a VBS script or add-in application in Outlook that accesses an Outlook.mailItem.GetInspector.WordEditor Property. The number of GDI objects increase without being released correctly.

RESOLUTION

To resolve this problem, apply the following hotfix package
981735 Description of the Office Outlook 2007 hotfix package (mso-x-none.msp, outlook-x-none.msp): April 27, 2010

MORE INFORMATION

For more information about the MailItem.GetInspector Property, visit the following Microsoft website:

http://msdn.microsoft.com/en-us/library/bb175499(office.12).aspx


For more information about the Inspector.WordEditor Property, visit the following Microsoft website:

http://msdn.microsoft.com/en-us/library/bb206728.aspx

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 981579 - Last Review: July 6, 2010 - Revision: 2.0
APPLIES TO
  • Microsoft Office Outlook 2007
Keywords: 
kbexpertisebeginner kbfix kbsurveynew kbqfe KB981579

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com