Article ID: 981584 - Last Review: March 23, 2010 - Revision: 1.1

The "Meiryo Bold" font may be used on some Microsoft Input Method Editors (IME) User Interface components where the "Meiryo Regular" font is expected

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Problem description

Consider the following scenario. You have a computer that is running Windows Vista or Windows Server 2008. After you install the update that is described in Microsoft Knowledge Base (KB) article 975929, the Meiryo Bold font or the Meiryo UI Bold font may be used for the Microsoft Input Method Editors (IME) Candidate List or for the Microsoft IME pad Character List. These lists are where the regular weight of the corresponding font family is expected. Additionally, this issue still occurs if you uninstall the update KB975929.

This article helps you fix the problem. To have us fix this problem for you, go to the "Fix it for me" section. If you would rather fix this problem yourself, go to the "Let me fix it myself" section.

CAUSE

Update KB975929 updates the registry entry for Meiryo Bold first, followed by Meiryo Regular, in the order in which the Microsoft IME is sensitive in retrieving font names.

Fix it for me

To fix this problem automatically, click the Fix this problem link. Then click Run the File Download dialog box, and follow the steps in this wizard.

Fix this problem
Microsoft Automated Troubleshooting Services: Microsoft Fix it 50379


Note This wizard may only be in English. However, the automatic fix also works for other language versions of Windows.

Note If you are not using the computer that has the problem, you can save the automatic fix to a flash drive or to a CD, and then you can run it on the computer that has the problem.

Now, go to the "Did this fix the problem?" section.

Let me fix it myself

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

To resolve this problem, you must reorder two string values that are associated with the Meiryo font in the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts registry subkey. To do this, follow these steps:
  1. Click Start, type regedit in the Start Search box, and then click regedit in the Programs list.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts
  3. Locate the value data "meiryo.ttc."
  4. Right-click the string value, click Rename, and then press CTRL + C to copy the string value to the Clipboard.
  5. Right-click the string value, and then click Delete.
  6. On the Edit menu, point to New, and then click String Value.
  7. Press CTRL + V to paste the same string value back from the Clipboard.
  8. Right-click the string value, and then click Modify.
  9. In the Value data box, type meiryo.ttc, and then click OK.
  10. Repeat steps 3 to 7 for the value data "meiryob.ttc."
  11. If you are running an x64-based or an ia64-based version of Windows, repeat steps 2 to 8 for the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Fonts
  12. Exit Registry Editor, and then restart the computer.

More information

For more information about the update KB975929, click the following article number to view the article in the Microsoft Knowledge Base:
975929  (http://support.microsoft.com/kb/975929/ ) The Meiryo UI font is available for Windows Vista and for Windows Server 2008

Did this fix the problem?

Check whether the problem is fixed. If the problem is fixed, you are finished with this article. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .


APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Keywords: 
kbexpertisebeginner kbfixme kbsurveynew KB981584