Silverlight pour Mac n'est pas reconnu ou que vous êtes continuellement invité à installer

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Sommaire

Symptômes

Lorsque vous essayez d'accéder à un site Web qui requiert Silverlight afficher le contenu, vous recevez un message d'erreur indiquant que vous devez installer Silverlight.

Cause

Ce comportement peut se produire pour plusieurs raisons :
  • Votre système possède une version antérieure du plug-in et ne répond pas à la configuration requise pour le plug-in qui utilise le site.
  • Vous n'avez pas le plug-in installé.
  • Le navigateur est paramétré pour s'« Exécuter à l'aide de Rosetta, » ce qui entraîne que l'ordinateur est identifié incorrectement comme un Mac PowerPC.

Résolution

Avant de déterminer comment résoudre le problème, vous devez évaluer l'environnement actuel dans lequel le logiciel est en cours d'exécution. Pour ce faire, procédez comme suit :
  1. Sur la Apple menu, sélectionnez À propos de ce Mac.
  2. Notez le type de processeur, vitesse, RAM et informations du système d'exploitation, comme certains sites Web ont des exigences spécifiques pour afficher leur contenu.
  3. Fermer la fenêtre.
  4. Fermez toutes les fenêtres de navigateur ouvertes.
  5. Double-cliquez sur l'icône de disque dur sur le bureau.
  6. Double-cliquez sur le dossier de bibliothèque.
  7. Ouvrez le dossier Plug-ins Internet.
  8. Existe-t-il un fichier nommé Silverlight.plugin ? Si ce fichier existe, le plug-in est installé. Pour déterminer la version, cliquez sur pour sélectionner le fichier. Ensuite, sélectionnez Obtenir des informations sur la Fichier menu. Notez le numéro de version s'affiche.
    • Si le numéro de version affiché est 1.0.xxx et votre type de processeur est un PowerPC, vous avez la bonne version du plug-in installé.
    • Si vous avez un processeur Intel, toutes les versions de Silverlight sont pris en charge. Mais nous vous recommandons d'exécuter la dernière version afin que vous pouvez accéder à des sites Web qui utilisent des fonctionnalités les plus récentes et tirer parti des améliorations de produit la plus récentes.
Nous pouvons maintenant traiter les causes et résolutions.

Votre système possède une version antérieure du plug-in et ne répond pas aux exigences du site Web

La cause la plus courante de ce problème est que le site Web utilise Silverlight 3 pour son contenu. Si un site nécessite la version 3, il reconnaît que si votre système répond à la demande. Si le système n'existe pas, vous êtes invité à mettre à niveau. Vous êtes dirigé vers le site de Silverlight. Si vous utilisez un PowerPC, le site reconnaît cela et que seule la version 1 peut être installée. (Cette situation devrait être traitée par l'équipe de support du site Web, la décision sur quelle version de Silverlight à utiliser est effectuée par les concepteurs de site Web.)

Vous n'avez pas le plug-in installé

Si Silverlight n'a pas encore été installé, procédez comme suit pour installer le plug-in :
  1. Démarrez un navigateur Web et visitez le site Web suivant :
    http://Silverlight.net/GetStarted/
  2. Accédez à la zone « Installer Silverlight » dans la partie inférieure droite de la fenêtre.
    • Si vous exécutez un processeur Intel, cliquez sur Mac Runtime en regard de « Silverlight 3 ».
    • Sinon, cliquez sur Runtime pour Mac PowerPC en regard de « Silverlight 1.0 ».
  3. Une fois le téléchargement terminé, l'installation doit démarrer automatiquement. Suivez les étapes de l'Assistant d'installation.
  4. Une fois l'installation terminée, vous devez être invité à quitter votre navigateur. Fermez les fenêtres du navigateur et redémarrez le navigateur. Le navigateur doit reconnaître le nouveau plug-in.
Remarque : Si vous rencontrez des problèmes avec l'installation, consultez l'article suivant de la Base de connaissances Microsoft pour plus d'informations sur la façon d'installer manuellement le plug-in :
970064 Comment faire pour supprimer et réinstaller manuellement Silverlight 2 pour Mac

Le navigateur est paramétré pour « Exécuter à l'aide de Rosetta, » qui entraîne l'ordinateur à être identifiés incorrectement comme un Mac basé sur PowerPC

Si le navigateur est configuré pour s'exécuter dans le moteur de Rosetta, elle identifiera correctement l'ordinateur comme un Mac basé sur PowerPC, ou le site Web ne peut pas reconnaître que l'appropriée du plug-in est installé.

Si le plug-in approprié est installé comme décrit dans la section précédente, procédez comme suit :
  1. Double-cliquez sur l'icône de disque dur sur le bureau.
  2. Choisissez le dossier Applications.
  3. Recherchez l'icône du navigateur que vous utilisez. Maintenez enfoncée la touche CTRL enfoncée et cliquez sur cette icône.
  4. Sélectionnez Obtenir des informations.
  5. Recherchez le Exécuter à l'aide de Rosetta l'option et assurez-vous que cette case à cocher n'est pas activée. Si elle est activée, désactivez la case à cocher. Fermer la fenêtre.
  6. Dans le menu Pomme, cliquez sur Redémarrer.
  7. Après le redémarrage de l'ordinateur, essayez à nouveau d'accéder au site Web qui a généré le message d'erreur.
Remarque : Si la version appropriée du plug-in n'est pas installée, assurez-vous que le Exécuter à l'aide de Rosetta case à cocher n'est pas sélectionnée et suivez les étapes décrites dans la section précédente pour installer le plug-in.

Propriétés

Numéro d'article: 981760 - Dernière mise à jour: dimanche 12 mai 2013 - Version: 5.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Silverlight for Macintosh
Mots-clés : 
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