文書番号: 981779 - 最終更新日: 2010年5月17日 - リビジョン: 2.0

Windows 7 または Windows Vista で未フォーマットのフロッピー ディスクを Windows エクスプローラーからフォーマットするとフォーマットに失敗する場合がある

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。

目次

すべて展開する | すべて折りたたむ

現象

内蔵型フロッピー ディスク ドライブが搭載されている Windows 7 または Windows Vista がインストールされたコンピューターで、未フォーマットのフロッピー ディスクを Windows エクスプローラーからフォーマットすると、以下のエラー メッセージが表示され、フロッピー ディスクのフォーマットに失敗する場合があります。

なお、フロッピー ディスクを USB フロッピー ディスク ドライブでフォーマットした場合は、この現象は発生しません。

Windows 7 の場合 :

補足 : Windows エクスプローラー (Explorer.exe) が動作を停止して、フロッピー ディスクのフォーマットに失敗します。

元に戻す画像を拡大する
エクスプローラーは動作を停止しました


Windows Vista の場合 :

元に戻す画像を拡大する
Windows は フォーマットを完了できませんでした

原因

Windows 7 および Windows Vista では、より厳密なクラスタ サイズの確認処理機能が追加されており、フォーマット処理の前に、フロッピー ディスクのジオメトリ情報が取得されます。しかし、未フォーマットのフロッピー ディスクからは正常なジオメトリ情報が取得できない場合があり、その際に不正な情報をもとにクラスタ サイズの計算が行われるために、この現象が発生します。

回避策

この現象を回避するには、以下の手順を実行してコマンド プロンプトからフロッピー ディスクをフォーマットしてください。
  1. フロッピー ディスク ドライブにフォーマットするフロッピー ディスクを挿入します。
  2. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、[プログラムとファイルの検索] に cmd と入力します。 Windows Vista をお使いの場合は、[検索の開始] に cmd と入力します。
  3. 検索結果の [プログラム] 一覧に表示された、[cmd.exe] をクリックします。
  4. [コマンド プロンプト] 画面が表示されたら、format a: と入力して Enter キーを押します。
  5. フロッピー ディスクのフォーマットが始まります。表示されるメッセージに従ってフォーマットを進めます。
  6. "フォーマットは完了しました。" とメッセージが表示されたらフォーマットは完了です。別のフロッピー ディスクを続けてフォーマットする場合は、Y キーを押して、フロッピー ディスク ドライブにフォーマットするフロッピー ディスクを挿入します。別のフロッピー ディスクのフォーマットをしない場合は、N キーを押して終了します。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

問題の再現手順

ここでは例として、Windows 7 の再現手順を説明します。
  1. 内蔵型フロッピー ディスク ドライブが搭載された Windows 7 の PC を用意します。
  2. [スタート] ボタンをクリックします。
  3. [コンピューター] をクリックします。
  4. [リムーバブル記憶域があるデバイス] の [フロッピー ディスク ドライブ (A:)] を右クリックし、[フォーマット] をクリックします。

結果

以下のエラー メッセージが表示されて、Windows エクスプローラーが動作を停止し、フロッピー ディスクのフォーマットに失敗します。
エクスプローラーが動作を停止しました

次のオンラインになるときに、問題の解決策をオンラインで確認でき、プログラムの再起動を試行できます。

この資料は以下の製品について記述したものです。
  • Windows 7 Enterprise
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
キーワード:?
kbbug kberrmsg kbtshoot kbexpertisebeginner kbharmony KB981779
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"