Stop error code 0x0000009F or Stop error code 0x000000FE on a Windows 7-based or Windows Vista-based computer that uses certain AMD USB EHCI host controllers

Article translations Article translations
Article ID: 982091 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • You have a Windows 7-based computer that uses certain AMD USB South Bridge EHCI host controllers.
  • You attach a USB device to the computer.
  • The computer enters sleep (S3) or hibernation (S4) and then resumes from sleep or from hibernation. This process is repeated several times.
In this scenario, you receive one of the following stop error messages:
Stop 0x9F
Stop 0xFE
Notes
  • This issue occurs on the systems that have the following chipsets and USB EHCI controllers:
    Collapse this tableExpand this table
    ChipsetDevice ID Vendor ID
    SB600
    South Bridge 4385h 1002h
    USB EHCI Controller 4386h 1002h
    SB700/SB710/SB750
    South Bridge 4385h 1002h
    USB EHCI Controller 4396h 1002h
    SB810/850/SB820M
    South Bridge 4385h 1002h
    USB EHCI Controller 4396h1002h
  • This issue might also occur on computers that are running Windows Vista, Windows Server 2008, or Windows Server 2008 R2.

CAUSE

AMD has identified an issue with the host controller. This issue causes the host controller to become unresponsive in specific circumstances. For example, this issue may occur if the USB device uses the periodic schedule on the USB host controller.

RESOLUTION

To have us fix the problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50402


Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Next, go to the "Did this fix the problem?" section.



Let me fix it myself

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , type Devmgmt.msc in the Search programs and files box, and then press ENTER.
  2. Expand Universal Serial Bus controllers.
  3. Locate and then double-click USB2 Enhanced Host Controller.
  4. Click the Advanced tab, and then click Device Instance Path in the Property list.
  5. Note the value that is displayed. The value will resemble the following:
    PCI\VEN_xxxx&DEV_yyyy&SUBSYS_zzzzvvvv&REV_ww\qqqqqqqq
    Notes
    • The xxxx placeholder represents the PCI vendor ID
    • The yyyy placeholder represents the PCI device ID
    • The zzzz placeholder represents the PCI subsystem vendor ID
    • The vvvv placeholder represents the PCI subsystem device ID
    • The ww placeholder represents the PCI device revision number
    • The qqqqqqqq placeholder represents the Device Instance ID
  6. Click Start
    Collapse this imageExpand this image
    Start button
    , type Devmgmt.msc in the Search programs and files box, and then press ENTER.
  7. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_xxxx&DEV_yyyy&SUBSYS_zzzzvvvv&REV_ww\qqqqqqqq\Device Parameters

    Note In this step, you must locate the registry subkey by using the value that you noted in step 5.
  8. On the Edit menu, point to New, and then click DWORD Value.
  9. Type EnHcPeriodicIdle, and then press ENTER.
  10. Right-click EnHcPeriodicIdle, and then click Modify.
  11. In the Value data box, type 0, and then click OK.
  12. Exit Registry Editor, and then restart the computer.


Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an e-mail.

MORE INFORMATION

Note Typically, a USB 2.0 Enhanced (EHCI) host controller will disable the periodic schedule if there are no periodic transfers scheduled, which helps to reduce power consumption by the host controller. By applying the fix that is described in the "Resolution" section, you will prevent the USB periodic schedule from being disabled when it is idle. In some situations, such as when a device that does not support USB Selective Suspend is attached to a USB host controller with this configuration, this might increase the power consumption of the system by approximately 5 percent. In order to prevent this, do not attach devices that do not support USB Selective Suspend (for example, certain USB storage devices) to a USB host controller that has this setting applied.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Properties

Article ID: 982091 - Last Review: January 9, 2012 - Revision: 5.0
APPLIES TO
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Business N 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Keywords: 
kbfixme kbmsifixme kbtshoot kbexpertisebeginner kbsurveynew kbprb KB982091

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com