"Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)" error when a client logs off from a terminal server session in Windows Server 2003 SP1 or in Windows Server 2003 SP2

Article translations Article translations
Article ID: 982362 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When a client logs off from a terminal server session on a terminal server that is running Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2), you may receive a Stop error that resembles the following on the terminal server:

Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)
When this issue occurs, all terminal server sessions may also stop responding on to the terminal server. Additionally, the following event is logged in the System log of the terminal server:


Event Type: Information
Event Source: Save Dump
Event Category: None
Event ID: 1001
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description: The computer has rebooted from a bugcheck. The bugcheck was: 0x000000ab ( parameter1 , parameter2 , parameter3 , parameter4 ). A dump was saved in: C:\WINDOWS\MEMORY.DMP.

CAUSE

This issue occurs because some session pool memory that has the GhA4 tag in the Win32k.sys file is leaked.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces the hotfixes that are described in the following Microsoft Knowledge Base articles. To view an article, click the article number.

901150 You may receive a “Stop 0x000000ab” error message when you log off a Terminal Services session on a Windows Server 2003 SP1-based Terminal Server

907242 You receive a "Stop 0x000000ab" error message when you log off from a Terminal Services session on a Windows Server 2003 SP1-based terminal server

910362 Error message when you log off from a Terminal Services session on a Windows Server 2003 Service Pack 1-based terminal server: "Stop 0x000000AB SESSION_HAS_VALID_POOL_ON_EXIT"

918673 You receive a "Stop 0x000000ab" error message when a Terminal Services client computer logs off from a Terminal Services session on a Windows Server 2003 SP1-based Terminal Services computer

923035 Stop error message when a Terminal Services client logs off from a session on a server that is running Windows Server 2003 with Service Pack 1: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"

924806 Stop error message when a client logs off a Terminal Services session on a server that is running Windows Server 2003 with Service Pack 1: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"

925919 Stop error message when a client computer logs off from a Terminal Services session on a server that is running Windows Server 2003 with SP1 or with SP2: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"

921282 The rules cannot be found when the workflow class is the second class in the code file in the Windows Workflow Foundation

939442 Stop error message when a client logs off from a Terminal Services session on a Windows Server 2003-based terminal server: "Stop 0x000000ab"

944916 Stop error message when a client logs off from a Terminal Services session on a server that is running Windows Server 2003 with SP1 or Windows Server 2003 with SP2: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"

946068 Stop error message on a terminal server that is running Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"

951749 Stop error message on a terminal server that is running Windows Server 2003 SP1 or Windows Server 2003 SP2: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"

959466 Stop error on a Windows Server 2003-based terminal server that has a third-party Input Method Editor (IME) installed: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.47091,863,68013-May-201014:08x86
For all supported x64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.47094,549,12013-May-201014:59x64
For all supported IA-64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.47095,594,62413-May-201014:54IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This hotfix includes all the earlier hotfixes that address some "Stop 0x000000AB" issues. The testing of the Win32k.sys driver for other tag memory leaks continues. Other tags memory leaks will be resolved when they are identified by specific cases.

The following is a cumulative list of all the tags that this hotfix addresses and that caused a memory leak:
  • Gadd
  • Gcac
  • Geto
  • Gffv
  • Gfnt
  • Ggb
  • Gglf
  • Ggls
  • Gh*5
  • GhA4
  • Ghtc
  • Ghx
  • Ghx4
  • Ghx7
  • GhxE
  • Gl*5
  • Gla4
  • Gla5
  • Glx4
  • Gpat
  • Gpfe
  • Gpff
  • Gpid
  • Gqnk
  • Gsp
  • Gtmp
  • Gtmw
  • Gtvp
  • Gump
  • Gxlt
  • knlf
  • Uscm
  • Usim
  • Usd1
  • UsdE
  • Usgh
  • Usjb
  • Usqm
  • Usrt
  • Ussy

Properties

Article ID: 982362 - Last Review: July 7, 2011 - Revision: 4.0
APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
Keywords: 
kbprb kbsurveynew kbexpertiseadvanced kbhotfixserver kbautohotfix kbqfe kbfix KB982362

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com