Scanning using a scanner on 64-bit Windows Vista or Windows 7 may cause a TWAIN aware application to hang.

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Article ID: 982436 - View products that this article applies to.
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Source: Microsoft Support

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RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

Symptoms



When a 32-bit TWAIN aware application scans using a WIA driver on a 64-bit Windows Vista or Windows 7 system, the TWAIN application may stop responding.

 

Cause



If you leave the scan dialog open for about ten minutes before you push the [Scan] button, the message used to transfer the scanned image from the WIA driver to the TWAIN application is not sent to the TWAIN application.

 

Resolution



This problem can be avoided by doing either of the followings:

 - Scan image soon after you open the scan dialog.

- Use a WIA aware application, not a TWAIN aware application.

 

More Information



This behavior is by design.

 

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Properties

Article ID: 982436 - Last Review: April 8, 2010 - Revision: 1.0
APPLIES TO
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Enterprise
  • Windows 7 Ultimate
  • Windows Vista Home Premium
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate
Keywords: 
kbrapidpub KB982436

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