El examen mediante un escáner puede hacer que una aplicación compatible con TWAIN se cuelgue

En este artículo se proporciona una solución para el problema de que el examen mediante un escáner puede provocar que una aplicación compatible con TWAIN se cuelgue.

Se aplica a: Windows 7 Service Pack 1
Número de KB original: 982436

Origen: Soporte técnico de Microsoft

Publicación rápida

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Síntomas

Cuando una aplicación compatible con TWAIN de 32 bits examina mediante un controlador WIA en un sistema Windows Vista o Windows 7 de 64 bits, la aplicación TWAIN puede dejar de responder.

Causa

Si deja abierto el cuadro de diálogo de examen durante unos 10 minutos antes de pulsar el botón [Examinar], el mensaje usado para transferir la imagen escaneada desde el controlador WIA a la aplicación TWAIN no se envía a la aplicación TWAIN.

Solución

Este problema se puede evitar mediante cualquiera de las siguientes acciones:

  • Digitalice la imagen poco después de abrir el cuadro de diálogo de examen.

  • Use una aplicación compatible con WIA, no una aplicación compatible con TWAIN.

Más información

Este comportamiento es una característica del diseño de la aplicación.

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