スキャナーを使用してスキャンすると、TWAIN 対応アプリケーションがハングする可能性があります

この記事では、スキャナーを使用してスキャンすると TWAIN 対応アプリケーションがハングする可能性がある問題の解決策について説明します。

適用対象: Windows 7 Service Pack 1
元の KB 番号: 982436

ソース: Microsoft サポート

迅速な発行

迅速な発行に関する記事では、Microsoft サポート organization内から直接情報が提供されます。 本明細書に含まれる情報は、新興または固有のトピックに応答して作成されるか、または他のサポート情報情報を補完するものである。

現象

64 ビット Windows Vista または Windows 7 システムで WIA ドライバーを使用して 32 ビットの TWAIN 対応アプリケーションがスキャンされると、TWAIN アプリケーションが応答を停止することがあります。

原因

[スキャン] ボタンを押す前に約 10 分間スキャン ダイアログを開いたままにした場合、WIA ドライバーから TWAIN アプリケーションにスキャンしたイメージを転送するために使用されるメッセージは TWAIN アプリケーションに送信されません。

解決方法

この問題は、次のいずれかの方法で回避できます。

  • スキャン ダイアログを開いた直後にイメージをスキャンします。

  • TWAIN 対応アプリケーションではなく、WIA 対応アプリケーションを使用します。

詳細

この動作は仕様です。

免責事項

マイクロソフトおよび/またはそのサプライヤーは、本ウェブサイトに掲載されているドキュメントおよび関連グラフィック(「素材」)に含まれる情報の適合性、信頼性、正確性について、いかなる目的でも表明または保証しません。 資料には技術的な不正確さまたは誤字が含まれる場合があり、予告なくいつでも改訂される場合があります。

適用法によって許容される最大限の範囲において、Microsoft および/またはそのサプライヤーは、明示、黙示、または法令に基づく表現、保証、またはタイトルの条件、非侵害、満足のいく条件または品質、特定の目的に対する商品性および適合性を含むがこれに限定されない、すべての表明、保証、および条件を、素材に関して否認し、除外します。