An access violation occurs on the System.EnterpriseServices.Thunk.Proxy.CoCreateObject method in a .NET Framework 2.0-based application

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Article ID: 982559 - View products that this article applies to.
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SYMPTOMS

You run a Microsoft .NET Framework 2.0-based application that calls the System.EnterpriseServices.Thunk.Proxy.CoCreateObject method. When the memory usage is high, the application crashes. Additionally, an access violation is logged in the Application log.

CAUSE

This problem occurs because of an issue in the intermediate language (IL) code that is generated by the managed C++ compiler. The issue breaks the address of a local variable.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have the .NET Framework 2.0 Service Pack 2 (SP2) or the .NET Framework 3.5 Service Pack 1 (SP1) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply the hotfix if the affected files are not being used.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Vista SP2 and of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
System.enterpriseservices.dll2.0.50727.4451258,04823-Apr-201011:55
System.enterpriseservices.wrapper.dll2.0.50727.4451113,66423-Apr-201012:21
For all supported x64-based versions of Windows Vista SP2 and of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
System.enterpriseservices.dll2.0.50727.4451245,76023-Apr-201011:55
System.enterpriseservices.wrapper.dll2.0.50727.4451133,12023-Apr-201011:55
For all supported IA-64-based versions of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
System.enterpriseservices.dll2.0.50727.4451245,76023-Apr-201011:54
System.enterpriseservices.wrapper.dll2.0.50727.4451175,61623-Apr-201011:54

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 982559 - Last Review: July 20, 2011 - Revision: 5.0
APPLIES TO
  • Microsoft .NET Framework 3.5 Service Pack 1
Keywords: 
kbhotfixserver kbexpertiseadvanced kbsurveynew kbqfe kbautohotfix KB982559

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