No se puede ejecutar la aplicación de inicio después de deshabilitar y volver a habilitar en MSConfig

Seleccione idioma Seleccione idioma
Id. de artículo: 982591 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo
Fuente: Soporte técnico de Microsoft

PUBLICACIONES RÁPIDAS

LOS ARTÍCULOS DE PUBLICACIÓN RÁPIDA PROPORCIONAN INFORMACIÓN QUE PROVIENE DIRECTAMENTE DE LA ORGANIZACIÓN DE SOPORTE TÉCNICO DE MICROSOFT. LA INFORMACIÓN QUE OFRECEN SE OFRECE COMO RESPUESTA A TEMAS ESPECÍFICOS Y ACTUALES, O BIEN APORTA UN SUPLEMENTO A LA INFORMACIÓN DE LA KNOWLEDGE BASE.

Síntomas



Cuando deshabilitar aplicaciones de inicio mediante MSConfig y, a continuación, volver a habilitarlas, dichas aplicaciones no pueden ejecutarse.

 

Reproduzca los pasos:

1. Agregar una clave de ejecutar como se muestra a continuación.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run

      Nombre de valor: el Bloc de notas

      Información del valor: %SysytemRoot%\system32\notepad.exe

      Tipo: REG_EXPAND_SZ

 

2. Confirme el Bloc de notas abrirá al iniciar sesión.

3. Abra MSConfig

4. Mover a ficha "Inicio".

5. No marque el elemento "notepad" (nombre de inicio es "sistema operativo Microsoft Windows") y aplicarlo.

6. Vuelva a comprobar y aplíquela.

7. Vea que la siguiente clave ha cambiado a REG_SZ.

      Nombre de valor: el Bloc de notas

      Información del valor: %SysytemRoot%\system32\notepad.exe

      Tipo: REG_SZ

 

8. Vea si abrirá el Bloc de notas cuando inicie sesión.

 

Se esperaba un resultado: el Bloc de notas se ejecutará tras el inicio de sesión

Resultado real: no se ejecutará el Bloc de notas.

 

 

 

Causa



Los siguientes datos del registro se guardan cuando se deshabilitan las aplicaciones de inicio. Cuando se vuelven a habilitar las aplicaciones, se restauran los datos del registro como tipo REG_SZ.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run

Al volver a habilitar una aplicación de inicio que requiere la ruta de acceso especificadas con el tipo del Registro REG_EXPAND_SZ de las variables de entorno, las variables de entorno ya no son utilizables y no se ejecutará la aplicación porque se restaura el registro como REG_SZ en lugar de REG_EXPAND_SZ.

 

Resolución



Hay dos soluciones posibles.

1. Antes de utilizar msconfig, asegúrese de que los registros pertinentes tienen ruta de acceso completa sin variables de entorno.


2. Después de que ocurra este problema, cambie el tipo de registro a REG_EXPAND_SZ.

a. en la ficha Inicio MSConfig, compruebe el comando para cada aplicación.
b. Si el comando tiene variables del entorno como % SystemRoot %, compruebe la ubicación para ver si está en el registro
c. Si está en el registro, no olvide la ubicación y el comando.
d. Inicie el Editor del registro haciendo clic en % SystemRoot%\regedit.exe.
e. Busque el registro que recordar en el paso c. y recuerda el nombre de valor del comando correspondiente.
f. Haga clic con el botón secundario en el valor y elimínelo
g. crear un nuevo valor con ? valor de cadena expandible ?
h. nombre el nuevo valor el nombre recordado en el paso e.
i. establece el comando que recuerda al paso c como los datos del valor del nuevo valor.

Importante: Asegúrese de que hacer una copia de seguridad del registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema.

 

Obtener más información



Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

 

RENUNCIA

MICROSOFT Y SUS PROVEEDORES NO SE RESPONSABILIZAN NI GARANTIZAN LA ADECUACIÓN O EXACTITUD DE LA INFORMACIÓN CONTENIDA EN LOS DOCUMENTOS Y LOS GRÁFICOS RELACIONADOS PUBLICADOS EN ESTE SITIO WEB (?LOS MATERIALES?) PARA NINGÚN FIN DETERMINADO. LOS MATERIALES PUEDEN INCLUIR INEXACTITUDES TÉCNICAS O ERRORES TIPOGRÁFICOS Y PUEDEN SER REVISADAS EN CUALQUIER MOMENTO SIN NOTIFICACIÓN PREVIA.

SIN PERJUICIO DE LAS GARANTÍAS IMPUESTAS POR LA LEY APLICABLE, MICROSOFT Y SUS PROVEEDORES DECLINAN TODO COMPROMISO, GARANTÍA O CONDICIÓN, YA SEAN EXPRESOS, IMPLÍCITOS O PREVISTOS POR NORMAS DISPOSITIVAS, INCLUIDOS ENTRE OTROS COMPROMISOS, GARANTÍAS Y CONDICIONES DE TITULARIDAD, AUSENCIA DE INFRACCIÓN, ESTADO O CALIDAD SATISFACTORIOS, COMERCIABILIDAD Y ADECUACIÓN PARA UN FIN EN PARTICULAR, EN RELACIÓN CON LOS MATERIALES.

Propiedades

Id. de artículo: 982591 - Última revisión: miércoles, 14 de abril de 2010 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows 7 Home Premium
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
Palabras clave: 
kbmt kbrapidpub KB982591 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 982591

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com