Los mensajes MIME o S/MIME que estén firmados o cifrados no se analizan correctamente cuando se utiliza el descodificador MIME/SMIME en BizTalk Server 2006 R2

Seleccione idioma Seleccione idioma
Id. de artículo: 982634 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Considere el siguiente escenario:
  • Crear una ubicación de recepción para la recepción y procesar mensajes MIME y S/MIME en Microsoft BizTalk Server 2006 R2.
  • Canalización que incluye el descodificador MIME/SMIME utiliza el componente de canalización en la ubicación de recepción.
  • Recibe un mensaje MIME o S/MIME firmado o cifrado en BizTalk Server 2006 R2.
En este escenario, puede experimentar uno de los problemas siguientes.

Problema 1

Se ha suspendido el el mensaje. Además, se graba un mensaje de error similar al siguiente en el registro de aplicación:
Tipo de suceso: error
Origen del suceso: BizTalk Server 2006
Categoría del suceso: BizTalk Server 2006
ID. de suceso: 5753
Descripción: un mensaje recibido por el adaptador "Nombre del adaptador >"en ubicación de recepción"< Nombre de la Ubicación de recepción >"con el identificador URI"<uri>"se ha suspendido.
Error detalles: se ha producido un error de ejecución de la canalización de recepción: "Nombre de canalización de >,< Nombre de ensamblado de canalización >, Versión = 1.0.0.0, Culture = neutral, PublicKeyToken =<token>"Origen:" MIME/SMIME descodificador "
Puerto de recepción: "< Puerto de recepción Nombre >"URI:"<uri>"Motivo: se ha producido un error de autenticación."Error al descodificar el mensaje S/MIME. El mensaje S/MIME puede no ser válido."

Problema 2

El mensaje se recibe en BizTalk Server 2006 R2. Sin embargo, los límites MIME se incluyen como parte del mensaje. Por lo tanto, el mensaje es incorrecto.

NotaEstos problemas también ocurren cuando se utiliza el adaptador de POP3 en la ubicación de recepción.

Causa

Este problema se produce debido a un error en el archivo exsmime.dll que se incluye con BizTalk Server 2006 R2. Causa de este error, el componente de canalización de descodificador MIME/SMIME no analiza correctamente los mensajes MIME y S/MIME en determinadas condiciones.

Solución

La revisión que resuelve este problema se incluye en el paquete de actualización acumulativa 2 para BizTalk Server 2006 R2 Service Pack 1.

Para obtener más información acerca de cómo obtener el paquete de actualización acumulativa, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2211420Paquete de actualizaciones 2 para BizTalk Server 2006 R2 Service Pack 1 de la actualización de acumulado
Para obtener más información acerca de las revisiones del Service Pack 1 de BizTalk Server 2006 R2, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
974563Lista de Microsoft BizTalk Server en caliente correcciones que se incluyen en el Service Pack 1 de BizTalk Server 2006 R2
Para obtener más información acerca de las revisiones de BizTalk Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2003907Información de las revisiones de BizTalk Server

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se refiere a:".

Propiedades

Id. de artículo: 982634 - Última revisión: miércoles, 28 de julio de 2010 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft BizTalk Server 2006 R2 Branch
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
Palabras clave: 
kbbiztalk2006r2presp2fix kbbtspipeline kbqfe kbautohotfix kbsurveynew kbexpertiseadvanced kbfix kbmt KB982634 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 982634

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com