Mensagens MIME ou S/MIME que são assinadas ou encriptadas não são analisadas correctamente quando utilizar o descodificador MIME/SMIME no BizTalk Server 2006 R2

Traduções de Artigos Traduções de Artigos
Artigo: 982634 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Considere o seguinte cenário:
  • Criar uma localização de recepção, a recepção e a processo MIME e S/MIME mensagens no Microsoft BizTalk Server 2006 R2.
  • Utilizar uma tubagem que inclui o descodificador MIME/SMIME componente de tubagem na localização recepção.
  • Recebe uma mensagem assinada ou codificada MIME ou S/MIME no BizTalk Server 2006 R2.
Neste cenário, poderá detectar um dos seguintes problemas.

Problema 1

a mensagem é suspensa. Além disso, uma mensagem de erro semelhante à seguinte é registada no registo de aplicações:
Tipo de evento: erro
Origem do evento: BizTalk Server 2006
Categoria do evento: BizTalk Server 2006
ID do evento: 5753
Descrição: uma mensagem recebida pelo adaptador "< Nome da placa >"em receber localização"< Receber Nome Localização >"com o URI"<uri>"é suspensa.
Erro detalhes: Ocorreu uma falha na execução da tubagem de recepção: "< Tubagem nome >,< Gasoduto nome de assemblagem >, Versão = 1.0.0.0, Culture = neutro, PublicKeyToken =<token>"Origem:" MIME/SMIME descodificador "
Receber porta: "< Receber Porta Nome >"URI:"<uri>"Motivo: Ocorreu uma falha de autenticação."Falha ao descodificar a mensagem S/MIME. A mensagem S/MIME pode não ser válida."

Problema 2

a mensagem é recebida pelo BizTalk Server 2006 R2. No entanto, o limite MIME está incluído como parte da mensagem. Por conseguinte, a mensagem é incorrecta.

NotaEstes problemas também ocorrerem quando utilizar o adaptador de POP3 na localização de recepção.

Causa

Este problema ocorre devido a um erro no ficheiro Exsmime.dll incluído no BizTalk Server 2006 R2. Devido a este erro de componente de tubagem MIME/SMIME descodificador não analisa correctamente mensagens MIME e S/MIME, sob certas condições.

Resolução

A correcção que resolve este problema está incluída em 2 de pacote de actualização cumulativa para o BizTalk Server 2006 R2 SP1.

Para mais informações sobre como obter o pacote de actualização cumulativa, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
22114202 Para o BizTalk Server 2006 R2 Service Pack 1 do pacote de actualização de cumulativo
Para mais informações sobre correcções do BizTalk Server 2006 R2 SP1, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
974563Lista do Microsoft BizTalk Server quente corrige que estão incluídas no BizTalk Server 2006 R2 Service Pack 1
Para mais informações sobre correcções do BizTalk Server, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
2003907Informações sobre correcções do BizTalk Server

Ponto Da Situação

A Microsoft confirmou que este é um problema dos produtos da Microsoft listados na secção "Aplica-se a".

Propriedades

Artigo: 982634 - Última revisão: 28 de julho de 2010 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft BizTalk Server 2006 R2 Branch
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
Palavras-chave: 
kbbiztalk2006r2presp2fix kbbtspipeline kbqfe kbautohotfix kbsurveynew kbexpertiseadvanced kbfix kbmt KB982634 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 982634

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com