Failback does not occur within the set time period in a Windows Server 2008-based failover cluster

Article translations Article translations
Article ID: 982636 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • You configure a failover cluster on some computers that are running Windows Server 2008.
  • You configure a preferred owner for a cluster resource group.
  • In the failback policy, you define a time period to failback the cluster resource group to the preferred owner.
In this scenario, the cluster resource group is not moved to the preferred owner within the set time period even though the preferred owner is available.

CAUSE

This issue occurs because the cluster service uses an incorrect method to move the resource to the preferred owner.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 SP2.  For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
For all supported x86-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Clussvc.exe6.0.6002.224012,338,81610-May-201014:32x86
For all supported x64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Clussvc.exe6.0.6002.224013,865,60010-May-201014:46x64
For all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Clussvc.exe6.0.6002.224016,472,19210-May-201014:45IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Bookmark: Manifests1
Additional files for all supported x86-based versions Windows Server 2008
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size2,224
Date (UTC)11-May-2010
Time (UTC)00:12
PlatformNot applicable
File nameX86_2a1a9104a9fb7a7e943e304c40467946_31bf3856ad364e35_6.0.6002.22401_none_11737e3e4aeee168.manifest
File versionNot applicable
File size711
Date (UTC)11-May-2010
Time (UTC)00:12
PlatformNot Applicable
File nameX86_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.0.6002.22401_none_bc32c3aeb7cecacf.manifest
File versionNot applicable
File size15,117
Date (UTC)10-May-2010
Time (UTC)18:43
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size2,240
Date (UTC)11-May-2010
Time (UTC)00:12
PlatformNot applicable
File nameWow64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.0.6002.22401_none_22a60984a48cfe00.manifest
File versionNot applicable
File size4,510
Date (UTC)10-May-2010
Time (UTC)18:33
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size2,240
Date (UTC)11-May-2010
Time (UTC)00:12
PlatformNot applicable
File nameWow64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.0.6002.22401_none_22a60984a48cfe00.manifest
File versionNot applicable
File size4,510
Date (UTC)10-May-2010
Time (UTC)18:33
PlatformNot applicable

Properties

Article ID: 982636 - Last Review: September 11, 2010 - Revision: 2.1
APPLIES TO
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 for Itanium-Based Systems
Keywords: 
kbclustering kbHotfixServer kbautohotfix kbsurveynew kbexpertiseadvanced kbqfe kbfix KB982636

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com