Non è possibile aprire la cassetta postale in un server Exchange Server 2010 usando Outlook
Numero KB originale: 982678
Sintomi
Quando si tenta di aprire la cassetta postale in un server Microsoft Exchange Server 2010 usando Outlook, viene visualizzato uno dei messaggi di errore seguenti:
Messaggio di errore 1:
Impossibile aprire le cartelle di posta elettronica predefinite. Tentativo di accesso a Microsoft Exchange non riuscito.
Messaggio di errore 2:
Outlook non può accedere. Verificare di essere connessi alla rete e di usare il nome del server e della cassetta postale appropriati.
Messaggio di errore 3:
Impossibile aprire le cartelle di posta elettronica predefinite. Il file path_to_OST non è un file di cartella offline.
Causa
Questo problema si verifica quando si verifica una delle condizioni seguenti:
Il ruolo cassette postali Exchange Server 2010 e il ruolo server accesso client (CAS) Exchange Server 2010 vengono installati nello stesso server. Pertanto, all'indirizzo di questo server fa riferimento la proprietà del database delle cassette postali RpcClientAccessServer. Quando si disinstalla il ruolo cas Exchange Server 2010 da questo server, la proprietà RpcClientAccessServer non viene modificata. La proprietà del database delle cassette postali fa ancora riferimento all'indirizzo del server Exchange Server 2010 originale, anche se Exchange Server cas 2010 non è installato in tale server.
Disinstallare il ruolo CAS di Exchange 2010 dal server. Tuttavia, il processo di disinstallazione non rimuove completamente tutte le impostazioni. La proprietà del database della cassetta postale RpcClientAccessServer fa ancora riferimento a questo indirizzo del server.
L'attributo
LegacyExchangeDN
nel database viene modificato in un valore non corretto.
Risoluzione
Per risolvere questo problema e modificare la proprietà del RpcClientAccessServer
database delle cassette postali con il valore corretto, seguire questa procedura:
Nota
Durante questo processo, l'attributo LegacyExchangDN
viene aggiornato al valore corretto per il server Exchange Server.
Fare clic su Start, scegliere Tutti i programmi, Exchange Server 2010 e quindi Fare clic su Exchange Management Shell.
Al prompt dei comandi digitare il
Get-MailboxDatabase <database_name> | fl Name, RpcClientAccessServer
cmdlet e quindi premere INVIO.Il valore restituito potrebbe non essere il nome di dominio completo (FQDN) del server CAS Exchange Server 2010 o della matrice CAS Exchange Server 2010. Se si verifica questo comportamento, digitare il
Set-MailboxDatabase <database_name> -RpcClientAccessServer <FQDN_of_CAS>
cmdlet e quindi premere INVIO.Nota
Il <segnaposto FQDN_of_CAS> è il nome di dominio completo del server CAS Exchange Server 2010 o della matrice CAS Exchange Server 2010.