Outlook을 사용하여 Exchange Server 2010 서버에서 사서함을 열 수 없습니다.

원본 KB 번호: 982678

증상

Outlook을 사용하여 Microsoft Exchange Server 2010 서버에서 사서함을 열려고 하면 다음 오류 메시지 중 하나가 표시됩니다.

  • 오류 메시지 1:

    기본 전자 메일 폴더를 열 수 없습니다. Microsoft Exchange에 로그온하지 못했습니다.

  • 오류 메시지 2:

    Outlook에서 로그온할 수 없습니다. 네트워크에 연결되어 있고 적절한 서버 및 사서함 이름을 사용하고 있는지 확인합니다.

  • 오류 메시지 3:

    기본 전자 메일 폴더를 열 수 없습니다. path_to_OST 파일은 오프라인 폴더 파일이 아닙니다.

원인

이 문제는 다음 조건 중 하나가 true일 때 발생합니다.

  • Exchange Server 2010 사서함 역할 및 Exchange Server 2010 CAS(클라이언트 액세스 서버) 역할이 동일한 서버에 설치됩니다. 따라서 이 서버의 주소는 RpcClientAccessServer 사서함 데이터베이스 속성에서 참조됩니다. 이 서버에서 Exchange Server 2010 CAS 역할을 제거하면 RpcClientAccessServer 속성이 변경되지 않습니다. 사서함 데이터베이스 속성은 Exchange Server 2010 CAS가 해당 서버에 설치되어 있지 않더라도 원래 Exchange Server 2010 서버 주소를 참조합니다.

  • 서버에서 Exchange 2010 CAS 역할을 제거합니다. 그러나 제거 프로세스가 모든 설정을 완전히 제거하지는 않습니다. RpcClientAccessServer 사서함 데이터베이스 속성은 여전히 이 서버 주소를 참조합니다.

  • LegacyExchangeDN 데이터베이스의 특성이 잘못된 값으로 변경됩니다.

해결 방법

이 문제를 resolve 사서함 데이터베이스 속성을 올바른 값으로 변경 RpcClientAccessServer 하려면 다음 단계를 수행합니다.

참고

이 프로세스 중에 LegacyExchangDN 특성은 Exchange Server 서버에 대한 올바른 값으로 업데이트됩니다.

  1. 시작을 클릭하고 모든 프로그램을 가리키고 Exchange Server 2010을 가리킨 다음 Exchange 관리 셸을 클릭합니다.

  2. 명령 프롬프트에서 cmdlet을 Get-MailboxDatabase <database_name> | fl Name, RpcClientAccessServer 입력한 다음 Enter 키를 누릅니다.

  3. 반환된 값은 Exchange Server 2010 CAS 서버 또는 Exchange Server 2010 CAS 배열의 FQDN(정규화된 도메인 이름)이 아닐 수 있습니다. 이 동작이 발생하면 cmdlet을 Set-MailboxDatabase <database_name> -RpcClientAccessServer <FQDN_of_CAS> 입력한 다음 Enter 키를 누릅니다.

    참고

    <FQDN_of_CAS> 자리 표시자는 Exchange Server 2010 CAS 서버 또는 Exchange Server 2010 CAS 배열의 FQDN입니다.