UseLegacyFB レジストリ値は、Outlook 2010 および Outlook 2013 では期待どおりに機能しません
元の KB 番号: 982698
現象
Windows レジストリにレジストリ値をUseLegacyFB
追加して、Microsoft Outlook 2010または Outlook 2013 を Office Outlook 2007 のように強制的に動作させる場合、値は Outlook によって無視されます。
原因
レジストリ値は UseLegacyFB
、Outlook 2010 または Outlook 2013 では使用されません。 既定では、メールボックスが Microsoft Exchange 2007 または Exchange 2010 サーバー上にある場合、Outlook 2007、Outlook 2010、および Outlook 2013 は Exchange 可用性サービスを使用して空き時間情報を検索します。 これは、パブリック フォルダーの空き時間情報を使用する Outlook 2003 以前のバージョンの Outlook からの変更です。
注:
パブリック フォルダーの空き時間情報が Outlook 2013 から削除されました。 Outlook 2013 の変更の詳細については、「 Office 2013 の変更」を参照してください。
Office Outlook 2007 では、次のレジストリ データを使用して、Outlook 2007 で Availability Service ではなくパブリック フォルダーの空き時間情報を強制的に使用できます。
キー: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\Calendar
名前: UseLegacyFB
型: DWORD
値: 1
Availability Service の問題のトラブルシューティングを行うシナリオによっては、このレジストリ データをクライアントに追加することで、Outlook 2007 でパブリック フォルダーの空き時間情報を強制的に使用することが必要になる場合があります。 このような状況では、レジストリ値が無視されるため、Outlook 2010 または Outlook 2013 でパブリック フォルダーの空き時間情報を強制的に UseLegacyFB
使用することはできません。
解決方法
Outlook 2010 または Outlook 2013 で Availability Service の問題をトラブルシューティングする場合は、Availability Service のログ記録を有効にすることができます。 これを行うには、次の手順を実行します。
Outlook を起動します。
[ファイル] タブの [オプション] を選択します。
[Outlook のオプション] ダイアログ ボックスで、[詳細設定] を選択します。
[その他] セクションで、[トラブルシューティング ログを有効にする (Outlook の再起動が必要)] チェック ボックスを選択し、[OK] を選択します。
Outlook を再起動する
Outlook が Availability Service を使用して空き時間情報を取得する場合、ログ ファイルは次のフォルダーに生成されます。
Outlook 2010
%temp%\OLKAS
ログ ファイルのファイル名には、次の形式が使用されます。
Yyyymmdd-hhmmssss-AS.log
たとえば、2010 年 3 月 30 日午後 2:14:20.0029 に生成されるログ ファイルには、次の名前が付けられます。
20100330-1411200029-AS.log
メモ帳などのテキスト エディターでこのログ ファイルを開き、ログ情報を調べます。
Outlook 2013
%temp%\Outlook のログ記録
ログ ファイルのファイル名には、次の形式が使用されます。
Outlook-########.etl
注:
顧客データを保護するために、高度なトレース ログ ファイルは、変換プロセスなしでは読み取ることができないバイナリ ファイルです。 ログ ファイルは、Microsoft カスタマー サポート サービスによって提供される安全な場所にアップロードできます。 Microsoft のサポート エンジニアは、分析のためにログ ファイルをダウンロードして変換できます。 詳細なトレース ログ ファイルの詳細については、「 Microsoft Outlook のグローバルログと高度なログ記録を有効にする方法」を参照してください。