Сообщение об ошибке "Не удалось подключиться к принтеру" при попытке создать соединения указания и печати с удаленным принтером на компьютере под управлением Windows 7 или Windows Server 2008 R2

Переводы статьи Переводы статьи
Код статьи: 982728 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

Рассмотрим следующий сценарий.
  • Имеется клиентский компьютер с ОС Windows 7 или Windows Server 2008 R2.
  • Вы пытаетесь создать соединение указания и печати с удаленным принтером на клиентском компьютере.
В этом случае происходит сбой операции и выводится следующее сообщение об ошибке:

=================
Название: Установить принтер
Текст: Подключение к принтеру
Windows не удается подключиться к принтеру.
Сведения: В ходе операции произошла ошибка 0x0000007e.
=================
Примечание. 0x0000007e/ERROR_MOD_NOT_FOUND. Не найден указанный модуль.


Поэтому драйвер принтера не может быть установлен, и вы не можете совместно использовать принтер на клиентском компьютере.

Причина

Эта проблема возникает из-за того, что после установки принтера Windows 7 или Windows Server 2008 R2 ищет файл Mscms.dll во вложенной папке, отличной от windows\system32.

Решение

Сведения об исправлении

Корпорация Майкрософт выпустила исправление, однако оно предназначено исключительно для устранения проблемы, описанной в этой статье. Его следует устанавливать только на компьютерах, где проявляется эта проблема. Исправление может проходить дополнительное тестирование. По этой причине корпорация Майкрософт рекомендует во всех случаях, когда проблема не создает серьезных сложностей, откладывать ее решение до выхода ближайшего обновления программного обеспечения, содержащего это исправление.

Если исправление доступно для загрузки, в начале этой статьи базы знаний должен быть раздел "Исправление доступно для загрузки". Если этого раздела нет, отправьте запрос на получение исправления в службу поддержки пользователей корпорации Майкрософт.

Примечание. При возникновении других проблем или необходимости устранить неполадки может потребоваться отдельный запрос на обслуживание. Дополнительные услуги по технической поддержке, не связанные с данным исправлением, оплачиваются на стандартных условиях. Чтобы просмотреть полный список телефонных номеров службы поддержки пользователей корпорации Майкрософт или создать отдельный запрос на обслуживание, посетите указанный ниже веб-сайт.
http://support.microsoft.com/contactus/?ws=support?ln=ru
Примечание. В форме "Исправление доступно для загрузки" указываются языки, для которых доступно исправление. Если в ней отсутствует нужный язык, значит для него нет исправления.

Необходимые условия

Это исправление устанавливается на компьютеры с системой Windows 7 или Windows Server 2008 R2.

Сведения о реестре

Для использования исправления, содержащегося в этом пакете, не требуется вносить изменения в реестр.

Необходимость перезагрузки

После установки этого исправления необходимо перезагрузить компьютер.

Сведения о замене исправлений

Это исправление не заменяет никакие ранее выпущенные исправления.

Сведения о файлах

Английская версия (США) этого обновления устанавливает файлы с атрибутами, указанными в приведенных ниже таблицах. Дата и время для файлов указаны в формате UTC. Дата и время для версий файлов на локальном компьютере отображаются с учетом часового пояса и перехода на летнее время. Кроме того, при выполнении определенных операций с файлами даты и время могут изменяться.
Заметки к сведениям о файлах для Windows 7 и Windows Server 2008 R2
Важно! Исправления для Windows 7 и Windows Server 2008 R2 включены в одни и те же пакеты. Однако на странице Hotfix Request (Запрос исправления) они указаны отдельно для каждой из операционных систем. Чтобы запросить исправление для одной или обеих операционных систем, выберите его в разделе "Windows 7/Windows Server 2008 R2". Сведения о том, для каких операционных систем предназначено исправление, см. в разделе "Актуальность" посвященной ему статьи.
  • Файлы с расширениями MANIFEST и MUM, устанавливаемые для каждой среды, указаны отдельно в разделе "Сведения о дополнительных файлах для Windows Server 2008 R2 и Windows 7". Эти файлы, а также связанные с ними CAT-файлы каталога безопасности, имеют очень важное значение для отслеживания состояния обновляемых компонентов. Файлы каталога безопасности (атрибуты не указаны) подписаны цифровой подписью Майкрософт.
Для всех поддерживаемых 32-разрядных (х86) версий Windows 7
Свернуть эту таблицуРазвернуть эту таблицу
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7600.20707768,00005-May-201007:05x86
Winprint.dll6.1.7600.1638529,69614-Jul-200901:16x86
Для всех поддерживаемых 64-разрядных (x64) версий Windows 7 и Windows Server 2008 R2
Свернуть эту таблицуРазвернуть эту таблицу
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7600.20707954,36805-May-201007:21x64
Winprint.dll6.1.7600.1638539,42414-Jul-200901:41x64
Для всех поддерживаемых версий Windows Server 2008 R2 с архитектурой IA-64
Свернуть эту таблицуРазвернуть эту таблицу
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7600.207072,051,58405-May-201005:49IA-64
Winprint.dll6.1.7600.1638590,62414-Jul-200901:50IA-64

Статус

Данное поведение является известной ошибкой продуктов Майкрософт, перечисленных в разделе "Информация в данной статье применима к".

Дополнительная информация

Подробные сведения о терминологии, используемой при описании обновлений программного обеспечения Майкрософт, см. в следующей статье базы знаний Майкрософт:
824684 Стандартные термины, используемые для описания обновлений программных продуктов Майкрософт

Сведения о дополнительных файлах

Сведения о дополнительных файлах для Windows 7 и Windows Server 2008 R2

Дополнительные файлы для всех поддерживаемых 32-разрядных (x86) версий Windows 7
Свернуть эту таблицуРазвернуть эту таблицу
File nameX86_1ed35da7eb57b41939c4d551f901f90a_31bf3856ad364e35_6.1.7600.20707_none_37e805b1b11de3bc.manifest
File version
File size718
Date (UTC)05-May-2010
Time (UTC)10:46
PlatformNot Applicable
File nameX86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7600.20707_none_30d3d6900cdc98b1.manifest
File version
File size4,844
Date (UTC)05-May-2010
Time (UTC)11:43
PlatformNot Applicable
Дополнительные файлы для всех поддерживаемых 64-разрядных (x64) версий Windows 7 и Windows Server 2008 R2
Свернуть эту таблицуРазвернуть эту таблицу
File nameAmd64_1ed35da7eb57b41939c4d551f901f90a_31bf3856ad364e35_6.1.7600.20707_none_9406a135697b54f2.manifest
File version
File size720
Date (UTC)05-May-2010
Time (UTC)10:46
PlatformNot Applicable
File nameAmd64_a82d49de4a58d02f63929c78e95ed2ee_31bf3856ad364e35_6.1.7600.20707_none_a3c47bd6b960ba03.manifest
File version
File size722
Date (UTC)05-May-2010
Time (UTC)10:46
PlatformNot Applicable
File nameAmd64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7600.20707_none_8cf27213c53a09e7.manifest
File version
File size4,845
Date (UTC)05-May-2010
Time (UTC)12:01
PlatformNot Applicable
Дополнительные файлы для всех поддерживаемых версий Windows Server 2008 R2 для платформы IA-64
Свернуть эту таблицуРазвернуть эту таблицу
File nameIa64_73672fa56aea7a3054afaab3375ebd81_31bf3856ad364e35_6.1.7600.20707_none_d40885115ecd51cc.manifest
File version
File size720
Date (UTC)05-May-2010
Time (UTC)10:46
PlatformNot Applicable
File nameIa64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7600.20707_none_30d57a860cdaa1ad.manifest
File version
File size4,844
Date (UTC)05-May-2010
Time (UTC)10:46
PlatformNot Applicable

Свойства

Код статьи: 982728 - Последний отзыв: 2 сентября 2013 г. - Revision: 9.0
Информация в данной статье относится к следующим продуктам.
  • Windows 7 Корпоративная
  • Windows 7 Домашняя базовая
  • Windows 7 Домашняя расширенная
  • Windows 7 Профессиональная
  • Windows 7 Максимальная
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Standard without Hyper-V
  • Windows Server 2008 R2 Enterprise without Hyper-V
  • Windows Server 2008 R2 Datacenter without Hyper-V
Ключевые слова: 
kbprb kbsurveynew kbexpertiseadvanced kbhotfixserver kbautohotfix kbqfe kbfix KB982728

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com