Funkce přímé rezervace neprovede úspěšnou rezervaci prostředku v aplikaci Outlook 2010

ID článku: 982774 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Odešlete-li v aplikaci Microsoft Office Outlook 2010 žádost o schůzku do poštovní schránky, v níž je nakonfigurována přímá rezervace, schůzka není úspěšně rezervována. V takové situaci se nezobrazí chybová zpráva. Pokud otevřete poštovní schránku, v níž je nakonfigurována přímá rezervace, je žádost o schůzku uložena ve složce Doručená pošta.

Poznámka: Když dřívější verze aplikace Outlook úspěšně zarezervovaly schůzku s poštovní schránkou, v níž je nakonfigurována přímá rezervace, nebyla nikdy žádost o schůzku odeslána do poštovní schránky prostředku. Proto žádost o schůzku ve složce Doručená pošta indikuje, že schůzka nebyla úspěšně zarezervována.

Příčina

Ve výchozím nastavení aplikace Outlook 2010 neimplementuje kód přímé rezervace, který je používán v dřívějších verzích aplikace Outlook. Místo toho je žádost o schůzku odeslána do poštovní schránky prostředku stejným způsobem, jímž je žádost o schůzku odeslána běžným účastníkům schůzky.

Řešení

Chcete-li tyto potíže vyřešit, použijte jednu z následujících metod a nakonfigurujte data registru tak, aby byla povolena funkce přímé rezervace aplikace Outlook:
  • Ruční úprava registru
  • Konfigurace registru pomocí zásad skupiny
  • Nasazení dat registru pomocí nástroje pro vlastní nastavení systému Office

Chcete-li, abychom funkci přímé rezervace aplikace Outlook povolili za vás, přejděte k části Automatická oprava. Chcete-li tyto potíže vyřešit sami, přejděte k části Manuální oprava.

Automatická oprava



Chcete-li tyto potíže odstranit automaticky, klikněte na tlačítko nebo odkaz Opravit. Potom klikněte v dialogovém okně Stažení souboru na položku Spustit a postupujte podle kroků v průvodci Opravit.


Opravit tyto potíže
Microsoft Fix it 50697


Poznámky
  • Tento průvodce může být k dispozici pouze v angličtině. Tato automatická oprava však funguje i pro ostatní jazykové verze systému Windows.
  • Pokud právě nejste u počítače, který má tyto potíže, můžete opravu uložit na jednotku USB Flash nebo na disk CD a spustit ji v příslušném počítači později.

Potom přejděte k části "Byly potíže vyřešeny?.



Manuální oprava

Metoda 1: Ruční úprava registru

Důležité: Tato část, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. V případě úpravy registru nesprávným způsobem však mohou nastat závažné problémy. Proto vždy pečlivě kontrolujte, zda postupujete přesně podle těchto kroků. Jako dodatečnou ochranu registr před úpravami zálohujte. Potom můžete v případě problému registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322756 Postup zálohování a obnovení registru v systému Windows
Chcete-li použít funkci přímé rezervace v aplikaci Outlook 2010, je třeba přidat data registru do klienta aplikace Outlook. Pomocí následujícího postupu přidejte tato data registru a povolte funkci přímé rezervace:
  1. Ukončete aplikaci Outlook.
  2. Spusťte Editor registru.
    • V systému Windows Vista klikněte na tlačítko Start
      Zmenšit tento obrázekZvětšit tento obrázek
      Tlačítko Start
      , do pole Zahájit hledání zadejte text regedit a stiskněte klávesu ENTER.

      Zmenšit tento obrázekZvětšit tento obrázek
      Povolení v nástroji Řízení uživatelských účtů
      Jestliže se zobrazí výzva k zadání hesla správce nebo k potvrzení, zadejte heslo nebo potvrďte akci.
    • V systému Windows XP klikněte na tlačítko Start, klikněte na položku Spustit, zadejte příkaz regedit a pak klikněte na tlačítko OK.
  3. Vyhledejte následující podklíč registru a vyberte jej:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Options\Calendar
  4. V nabídce Úpravy přejděte na příkaz Nový a potom klikněte na příkaz Hodnota DWORD.
  5. Zadejte text EnableDirectBooking a potom stiskněte klávesu ENTER.
  6. Klikněte pravým tlačítkem na položku EnableDirectBooking a pak klikněte na příkaz Změnit.
  7. Do pole Údaj hodnoty zadejte hodnotu 1 a klikněte na tlačítko OK.
  8. Ukončete program Editor registru.
  9. Spusťte aplikaci Outlook.

Metoda 2: Konfigurace registru pomocí zásad skupiny

Data registru, která jsou vyžadována pro povolení funkce přímé rezervace v aplikaci Outlook, lze nakonfigurovat pomocí zásad skupiny. Výchozí šablona zásad skupiny (Outlk14.adm) pro aplikaci Outlook 2010 neobsahuje nastavení zásad, které řídí funkci přímé rezervace aplikace Outlook. Proto je k povolení funkce přímé rezervace pomocí zásad skupiny třeba použít vlastní šablonu zásad skupiny.

Chcete-li toto nastavení nasadit pomocí vlastní šablony zásad skupiny, postupujte takto:
  1. Na webu služby Stažení softwaru je k dispozici ke stažení následující soubor:


    Zmenšit tento obrázekZvětšit tento obrázek
    Stáhnout
    Stáhnout balíček Outlk14-DirectBooking.zip

    Další informace o tom, jak stahovat soubory podpory společnosti Microsoft, naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
    119591 Jak získat soubory podpory společnosti Microsoft ze serverů služeb online
    Tento soubor byl zkontrolován na výskyt virů. Společnost Microsoft použila ke kontrole tohoto souboru nejnovější antivirový software, který byl v době jeho publikování k dispozici. Po publikování je soubor uložen na zabezpečených serverech neumožňujících neoprávněné změny souborů.
  2. Rozbalte vlastní šablonu ADM z balíčku Outlk14-DirectBooking.zip.

    Poznámka: Vlastní šablona ADM obsahuje následující text.
    CLASS MACHINE
    CLASS USER
    
       CATEGORY !!L_MicrosoftOfficeOutlookDirectBooking
             POLICY !!L_TurnOnOffDirectBooking
                 KEYNAME "Software\Policies\Microsoft\Office\14.0\Outlook\Options\Calendar"
                 EXPLAIN !!L_TurnOnOffDirectBookingExplain
                 VALUENAME "EnableDirectBooking"
                 VALUEON NUMERIC 1
                 VALUEOFF NUMERIC 0
             END POLICY
          END CATEGORY
    [strings]
    L_Version="14.0.4760.1000"
    L_LCID="1029"
    L_MicrosoftOfficeOutlookDirectBooking="Přímá rezervace aplikace Outlook 2010"
    L_TurnOnOffDirectBooking="Povolit nebo zakázat přímou rezervaci"
    L_TurnOnOffDirectBookingExplain="Tato zásada řídí funkci přímé rezervace aplikace Outlook 
    v aplikaci Outlook 2010 \n \n Ve výchozím nastavení aplikace Outlook 2010 neimplementuje kód přímé rezervace,
    který je používán v dřívějších verzích aplikace Outlook. Žádost o schůzku je odeslána do poštovní schránky
    prostředku stejným způsobem, jímž je žádost o schůzku odeslána běžným účastníkům schůzky.\n \n
    Tuto zásadu pro konfiguraci použití kódu přímé rezervace v aplikaci Outlook použijte vždy, když
    do pole Prostředky v žádosti o schůzku přidáte poštovní schránku.\n \n
    Pokud tuto zásadu zakážete nebo nenakonfigurujete a odešlete žádost o schůzku
    do poštovní schránky s nakonfigurovanou přímou rezervací, není schůzka úspěšně
    rezervována. V takové situaci se nezobrazí chybová zpráva. Pokud otevřete poštovní schránku,
    v níž je nakonfigurována přímá rezervace, je žádost o schůzku uložena ve složce Doručená pošta."
  3. Přidejte soubor Outlk14-DirectBooking.adm do Editoru zásad skupiny.

    Poznámka: Kroky pro přidání souboru ADM do Editoru zásad skupiny se liší v závislosti na tom, jakou verzi systému Windows používáte. Rovněž vzhledem k tomu, že se může stát, že zásady budou uplatněny pro organizační jednotku, a nikoli pro celou doménu, mohou se kroky lišit také v tomto aspektu. Proto doporučujeme vyhledat další informace v dokumentaci k systému Windows.

    Po přidání šablony ADM do Editoru zásad skupiny přejděte ke kroku 4.
  4. V Editoru zásad skupiny proveďte následující kroky:
    1. Rozbalte položku Konfigurace uživatele.
    2. Rozbalte položku Zásady.
    3. Rozbalte položku Šablony pro správu: Definice zásad.
    4. Rozbalte položku Klasické šablony pro správu (ADM) a vyhledejte uzel zásad pro vlastní šablonu. V tomto umístění je uložena vlastní šablona ADM, kterou jste rozbalili v kroku 2. Tato šablona má název Přímá rezervace aplikace Outlook 2010.

      Zmenšit tento obrázekZvětšit tento obrázek


  5. Klikněte na položku Přímá rezervace aplikace Outlook 2010.
  6. V části Nastavení dvakrát klikněte na položku Povolit nebo zakázat přímou rezervaci.
  7. Klikněte na přepínač Povoleno a potom na tlačítko OK.
Jakmile tuto zásadu povolíte, bude nastavení této zásady použito pro klientské pracovní stanice aplikace Outlook po dokončení replikace aktualizace zásad skupiny. Chcete-li tuto změnu otestovat, spusťte v klientské pracovní stanici z příkazového řádku následující příkaz:
gpupdate /force
Po spuštění tohoto příkazu spusťte Editor registru v klientské pracovní stanici a ověřte, zda v klientu existují následující data registru:
Klíč:
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\Options\Calendar

DWORD: EnableDirectBooking
Hodnota:1
Pokud se tato data v registru zobrazí, je nastavení zásad skupiny v tomto klientu použito. Spusťte aplikaci Outlook a ověřte, zda touto změnou byly potíže vyřešeny.

Metoda 3: Nasazení dat registru pomocí nástroje pro vlastní nastavení systému Office

Data registru můžete rovněž nasadit pomocí možnosti Add registry entries (Přidat položky registru) v nástroji pro vlastní nastavení systému Office (OCT). Použijte následující postup a pomocí nástroje OCT nasaďte data registru, která znovu povolují použití funkce přímé rezervace v aplikaci Outlook 2010.

Poznámka: Chcete-li použít nástroj OCT, je třeba, abyste používali edici Enterprise systému Office 2010. Používáte-li edici Retail systému Office 2010, zobrazí se při pokusu o spuštění nástroje OCT následující chybová zpráva:
Soubory potřebné ke spuštění nástroje pro vlastní nastavení systému Office nebyly nalezeny. Spusťte instalační program z umístění instalace opravňujícího produktu.
  1. Nástroj OCT spusťte pomocí příkazu podobného následujícímu:
    \\název_serveru\název_sdílené_složky\Office2010\Setup.exe /admin
  2. V dialogovém okně Select Product (Vybrat produkt) klikněte na položku Create a new Setup customization file for the following product (Vytvořit nový soubor vlastního nastavení pro následující produkt).
  3. V dialogovém okně Select your product (Vybrat produkt) vyberte produkt systému Office. Poté klikněte na tlačítko OK.
  4. V navigačním podokně nástroje OCT vyberte položku Add registry entries (Přidat položky registru) a pak klikněte na tlačítko Add (Přidat).
  5. V dialogovém okně Add/Modify Registry Entry (Přidat nebo změnit položku registru) zadejte následující nastavení a pak klikněte na tlačítko OK:
    • Kořen: HKEY_CURRENT_USER
    • Datový typ: REG_DWORD
    • Klíč: Software\Microsoft\Office\14.0\Outlook\Options\Calendar
    • Název hodnoty: EnableDirectBooking
    • Údaj hodnoty: 1
    Na následujícím obrázku je zobrazeno provedení těchto změn v dialogovém okně Add/Modify Registry Entry (Přidat nebo změnit položku registru):

    Zmenšit tento obrázekZvětšit tento obrázek
    Dialogové okno Add/Modify Registry Entry (Přidat nebo změnit položku registru)


    Jakmile v dialogovém okně Add/Modify Registry Entry (Přidat nebo změnit položku registru) kliknete na tlačítko OK, nástroj OCT zobrazí data registru jako na následujícím obrázku:

    Zmenšit tento obrázekZvětšit tento obrázek
    Nástroj pro vlastní nastavení systému Office


  6. Proveďte všechny zbývající úkoly v nástroji OCT a pak soubor MSP uložte.
  7. Nasaďte systém Office 2010 s využitím tohoto souboru MSP.
Další informace o nástroji pro vlastní nastavení systému Office v systému Office 2010 naleznete v následujícím tématu na webu Microsoft TechNet:
Přehled vlastního nastavení pro systém Office 2010

Byly potíže vyřešeny?

  • Ověřte, zda jsou potíže vyřešeny. Jsou-li potíže vyřešeny, v tomto článku již pro vás nejsou žádné potřebné informace. Pokud potíže přetrvávají, můžete kontaktovat podporu.
  • Uvítáme vaše názory. Chcete-li nám sdělit svůj názor nebo nahlásit potíže s tímto řešením, uveďte poznámky v blogu Fix it for me (Automatická oprava) nebo nám odešlete e-mailovou zprávu.

Další informace

Další informace o konfiguraci poštovní schránky pro přímou rezervaci pomocí aplikace Outlook naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
291616 Přímá rezervace zdroje v aplikaci Outlook
Jsou-li poštovní schránky prostředků, u nichž je nakonfigurováno použití funkce přímé rezervace aplikace Outlook, uloženy na poštovním serveru Exchange Server 2007 nebo Exchange Server 2010, doporučujeme provést migraci těchto prostředků na prostředky systému Exchange 2007 nebo Exchange 2010. Poštovní schránky prostředků systému Exchange 2007 a Exchange 2010 poskytují širší škálu funkcí. Tyto poštovní schránky rovněž poskytují správu na straně serveru s využitím prostředí Exchange Management Shell nebo Konzoly pro správu serveru Exchange, které zjednodušují správu poštovních schránek prostředků.

Další informace o postupu při upgradu poštovní schránky prostředku přímé rezervace aplikace Outlook na poštovní schránku prostředku systému Exchange 2007 naleznete v následujícím tématu na webu Microsoft TechNet: Další informace o poštovních schránkách prostředků systému Exchange 2007 naleznete v následujícím tématu na webu Microsoft TechNet:
Plánování a správa poštovních schránek prostředků
Poznámka: Toto je článek určený k rychlému zveřejnění, který vydala přímo služba podpory společnosti Microsoft. Uvedené informace jsou poskytovány jako odpověď na vzniklé problémy. Vzhledem k požadavku na rychlé zveřejnění je možné, že zpráva obsahuje typografické chyby, a může být kdykoli bez ohlášení revidována. Další pokyny naleznete v dokumentu Podmínky užití.

Vlastnosti

ID článku: 982774 - Poslední aktualizace: 20. prosince 2011 - Revize: 1.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Outlook 2010
Klíčová slova: 
kbgraphxlink kberrmsg kbtshoot kbexpertiseinter kbsurveynew kbprb kb16bitonly kbmsifixme kbfixme KB982774

Dejte nám zpětnou vazbu