Article ID: 983014 - Last Review: August 26, 2011 - Revision: 2.2

You cannot start Outlook 2010 after you uninstall Business Connectivity Services

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SYMPTOMS

Consider the following scenario:
  • You install Microsoft Office 2010.
  • You have a server that is running Microsoft SharePoint Server 2010 for which an Enterprise client access license (CAL) is enabled.
  • From the SharePoint 2010 server, you take an external list offline to Microsoft Outlook 2010, and Outlook 2010 is associated with a Business Connectivity Services (BCS) Simple Solution. Or, you install a BCS Declarative Solution to Outlook 2010.
  • At a later date, you uninstall Business Connectivity Services from Office 2010. To do this, you follow these steps:
    1. In Control Panel, in the Programs and Features item, you select Microsoft Office 2010 in the list of programs that are installed.
    2. On the toolbar, you click Change. The Office 2010 installation program starts.
    3. You select Add or Remove Features, and then you click Continue.
    4. Under Microsoft Outlook, you expand Office Shared Features, you click the icon next to Business Connectivity Services, and in the drop-down list, you select Not Available.
    5. You click Continue. Then, the Outlook installation program removes Business Connectivity Services from the computer.
In this scenario, when you try start Outlook 2010 after you remove the BCS feature, Outlook 2010 does not start, and you receive the following error message:

Cannot start Microsoft Outlook. Cannot open the Outlook window.

Additionally, this issue occurs with the stand-alone version of Outlook 2010.

CAUSE

This issue occurs because, when you uninstall Business Connectivity Services from Office 2010, all the files for BCS are removed. However, the Outlook profile still has references to these files. When you try to start Outlook 2010, these files cannot be found, and this prevents Outlook 2010 from starting.

RESOLUTION

To resolve this issue, you must reinstall Business Connectivity Services, and then you must uninstall the BCS solutions directly.

Install Business Connectivity Services

  1. In Control Panel, under Programs, click Uninstall a program.
  2. For Office 2010:
    • Select Microsoft Office 2010, and then on the toolbar, click Change.
    For Outlook 2010:
    • Select Microsoft Outlook 2010 , and then on the toolbar, click Change.
  3. Select Add or Remove Features, and then click Continue.
  4. Expand Office Shared Features, click the icon next to Business Connectivity Services, and then click Run from my computer.
  5. Click Continue, and then complete the installation of the Business Connectivity Services. If you installed Office 2010 or Outlook 2010 from a disc, you are prompted to insert the installation disc.

Uninstall BCS Solutions

  1. In Control Panel, under Programs, click Uninstall a program.
  2. In the list of programs that are installed, select the BCS solution that you want to uninstall.
  3. On the toolbar, click Uninstall.
  4. Click Yes to uninstall the BCS solution.
  5. Follow the instructions to uninstall the solution.

APPLIES TO
  • Microsoft Outlook 2010
  • Microsoft Outlook 2010 with Business Contact Manager
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