Windows 7 および Windows Vista などで Microsoft IME を使用している場合、文字列の変換時に F8 キー、F9 キー または F10 キーを押すと変換文字列が消える場合がある

文書番号: 983135 - 対象製品
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目次

現象

Windows 7、Windows Vista、Windows Server 2008 R2 および Windows Server 2008 で、日本語入力システムに Microsoft IME を使用している場合、入力した文字列の変換時に、F8 キー、F9 キー、または F10 キーを押すと、変換文字列が消える場合があります。また、現象が発生した場合、そのまま続けて F8 キー、F9 キー、または F10 キーを押すと変換文字列が再表示されます。

補足 : この現象は、日本語入力システムに Microsoft Office IME 2007 を使用している場合は発生しません。

原因

Microsoft IME には、文字列を変換する時にカーソル位置の前後の内容を参照して、より適切な変換候補を表示する機能が実装されています。この機能は、この機能に対応したアプリケーション上で Microsoft IME を使っている場合にのみ使用できます。この現象は、この機能の内部処理に問題があるために発生します。

たとえば、最初に "を" などの接続詞を入力して確定し、"を" の前にカーソルを移動して、"マイクロソフト" と入力し変換すると、Microsoft IME の内部ではカーソル位置の前後を参照し "マイクロソフトを" と解釈します。この状態で F8 キーなどを押して文字列を変換すると、内部処理の問題で変換候補の "マイクロソフト" が消えてしまう場合があります。

回避策

この現象を回避するには、以下の手順を実行してください。

ここでは、例として Windows 7 と Windows Vista の手順を説明しています。

Windows 7 の場合

  1. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、[コントーロール パネル] をクリックします。
  2. [コントロール パネル] 画面の [表示方法] の [カテゴリ] をクリックし、[キーボードまたは入力方法の変更] をクリックします。
  3. [地域と言語] 画面で、[キーボードと言語] タブをクリックし、[キーボードの変更] ボタンをクリックします。
  4. [テキスト サービスと入力言語] 画面で、[全般] タブをクリックします。
  5. [インストールされているサービス] で [Microsoft IME] をクリックし、[プロパティ] ボタンをクリックします。
  6. [Microsoft IME のプロパティ] 画面で、[変換] タブをクリックし、[カーソル位置の前後の内容を参照して変換を行う] のチェック ボックスをオフにします。
  7. [Microsoft IME のプロパティ] 画面で、[OK] をクリックします。
  8. [テキスト サービスと入力言語] 画面で、[OK] をクリックします。
  9. [地域と言語] 画面で、[OK] をクリックします。
  10. [コントロール パネル] 画面の [ファイル] の [閉じる] をクリックします。

Windows Vista の場合

  1. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、[コントーロール パネル] をクリックします。
  2. [コントロール パネル] 画面の [キーボードまたは入力方法の変更] をクリックします。[キーボードまたは入力方法の変更] が無い場合は、[地域と言語] をダブル クリックします。
  3. [地域と言語のオプション] 画面で、[キーボードと言語] タブをクリックし、[キーボードの変更] ボタンをクリックします。
  4. [テキスト サービスと入力言語] 画面で、[全般] タブをクリックします。
  5. [インストールされているサービス] で [Microsoft IME] をクリックし、[プロパティ] ボタンをクリックします。
  6. [Microsoft IME のプロパティ] 画面で、[変換] タブをクリックし、[カーソル位置の前後の内容を参照して変換を行う] のチェック ボックスをオフにします。
  7. [Microsoft IME のプロパティ] 画面で、[OK] をクリックします。
  8. [テキスト サービスと入力言語] 画面で、[OK] をクリックします。
  9. [地域と言語のオプション] 画面で、[OK] をクリックします。
  10. [コントロール パネル] 画面の [ファイル] の [閉じる] をクリックします。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

問題の再現手順

  1. [ワードパッド] を起動します。
  2. と入力し、文字を確定します。
  3. の前にカーソルを移動します。
  4. マイクロソフト と入力し、スペースを 1 回押して 全角カタカナの "マイクロソフト" と表示されている状態にします。(この時、変換候補のリストは表示されていません。)
  5. F8 キーを押します。

結果

変換文字列が消えます。

プロパティ

文書番号: 983135 - 最終更新日: 2010年4月26日 - リビジョン: 1.0
この資料は以下の製品について記述したものです。
  • Windows 7 Enterprise
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
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