A NDR is not generated when an email message is not delivered after you set the value for "Maximum number of recipients" of "Transport Settings" to 0 on an Exchange Server 2007 server

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Article ID: 983447 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario. You set the value for "Maximum number of recipients" in the "Transport Settings" to 0. You do this in Exchange Management Console on a Microsoft Exchange Server 2007 server. In this scenario, users cannot send email messages. Additionally, a Non Delivery Report (NDR) is not generated if someone tries to send an email message to one or more recipients.
 
Notes 
  • You expect a NDR to generate a 550 5.5.3 error message which indicates that there are too many recipients.
  • You can use the Set-TransportConfig cmdlet in Exchange Management Shell to set the MaxRecipientEnvelopeLimit parameter to 0. This setting restricts users to send email messages.

CAUSE

This issue occurs because a NDR message has a recipient that is blocked by the Exchange Server 2007 server. However, a NDR is a system message which should be delivered.

RESOLUTION

To resolve this problem, install the following update rollup:
2279665 Description of Update Rollup 1 for Exchange Server 2007 Service Pack 3

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the Set-TransportConfig cmdlet, visit the following Microsoft website:
General information about the Set-TransportConfig cmdlet

Properties

Article ID: 983447 - Last Review: September 9, 2010 - Revision: 2.0
APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 3
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbfix kbqfe kbhotfixrollup kbexpertiseinter kbsurveynew KB983447

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