Article ID: 983545 - Last Review: August 27, 2010 - Revision: 6.0

Stop error when you add RAM by using the Hot Add Memory feature in a virtual machine that is running Windows 7

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SYMPTOMS

Consider the following scenario. You use the Hot Add Memory feature to add a large amount of random access memory (RAM) to a virtual machine. The virtual machine is running an x86-based version of Windows 7 Enterprise edition or of Windows 7 Ultimate edition. In this scenario, a memory corruption occurs. Because of this memory corruption, you receive a Stop error message. Additionally, the virtual machine restarts automatically.

Note This memory corruption occurs when the total amount of RAM is equal to or larger than the supported memory limit of the operating system that is running on the virtual machine.

To reproduce this issue, see the "Sample scenario" section.

CAUSE

When you use the hot add memory feature to add RAM to a virtual machine that is running an x86 edition of Windows 7, the maximum memory that you can add is 4GB. This is specified in the Windows SKU license.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running a virtual machine that is running an x86-based version of Windows 7 Enterprise edition or of Windows 7 Ultimate edition.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 file information note
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows 7" section. MANIFEST files and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntkrnlpa.exe6.1.7600.207133,964,80014-May-201002:47Not applicable
Ntoskrnl.exe6.1.7600.207133,908,99214-May-201002:47Not applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Sample scenario

Consider the following scenario:
  • You have a virtual machine that is running a 32-bit version of Windows 7. The RAM that is attached to this virtual machine is less than 4 gigabytes (GB).
  • You use the Hot Add Memory feature to add RAM to the virtual machine. After you do this, the total amount of RAM is greater than 4 GB.
In this scenario, you receive a Stop error message. Then, the virtual machine restarts automatically.


For more information about memory limits for Windows releases, visit the following Microsoft Developer Network (MSDN) website:
Memory limits for Windows releases (http://msdn.microsoft.com/library/aa366778(VS.85).aspx)
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size1,674
Date (UTC)14-May-2010
Time (UTC)14:48
PlatformNot applicable

File nameX86_8e707ab4c7020ba1555a99fa23247955_31bf3856ad364e35_6.1.7600.20713_none_256035b8faf3a8ce.manifest
File versionNot applicable
File size697
Date (UTC)14-May-2010
Time (UTC)14:48
PlatformNot applicable

File nameX86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.20713_none_6cda09212e5d48d3.manifest
File versionNot applicable
File size16,151
Date (UTC)14-May-2010
Time (UTC)09:30
PlatformNot applicable

APPLIES TO
  • Windows 7 Enterprise
  • Windows 7 Ultimate
Keywords: 
kbqfe kbhotfixserver kbfix kbprb kbautohotfix kbsurveynew kbexpertiseinter KB983545