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Article ID: 934013 - Last Review: April 10, 2008 - Revision: 1.1

Event ID 1000 when you use the Binary protocol or the Tagged Binary Core Protocol to print from a PostScript printer on a Windows Vista-based computer: "Faulting application printdrvstress.exe"

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SYMPTOMS

When you use the Binary protocol or the Tagged Binary Core Protocol (TBCP) to print from a PostScript printer on a Windows Vista-based computer, the Printer Spooler service stops responding. Or, the print application closes with an error message. Additionally, the following event is logged in the Application log:
Source: Application Error
Event ID: 1000
Information: Faulting application printdrvstress.exe, version 6.0.6000.16386, time stamp 0x454a010d, faulting module ntdll.dll, version 6.0.6000.16386, time stamp 0x4549bdc9, exception code 0x80000003, fault offset 0x00042ea8, process id 0x36c, application start time 0x01c74c0a5dea560b.

CAUSE

When the Pscript5.dll module transfers font data to a PostScript printer, the transfer buffer size may not be calculated correctly. The transfer buffer size depends on the size of the font file. Therefore, the Pscript5.dll module accesses outside the transfer buffer, and an access violation occurs in the Printer Spooler service.

RESOLUTION

To resolve this issue, install Windows Vista Service Pack 1.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791  (http://support.microsoft.com/kb/935791/ ) How to obtain the latest Windows Vista service pack

WORKAROUND

To work around this issue, follow these steps:
  1. Click Start, type Printers in the Start Search box, and then click Printers.
  2. Right-click the printer, and then click Properties.
  3. Click the Device Settings tab, and then click Output Protocol.
  4. In the list of protocols, click the ASCII protocol, and then click OK.
  5. Click Start, type services in the Start Search box, and then click services.
  6. Click the Printer Spooler service, and then click Restart Service on the toolbar.
  7. Try to print again.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business N 64-bit Edition
  • Windows Vista Home Basic N 64-bit Edition
Keywords: 
kbharmony kbprb kbexpertiseinter kbtshoot binary KB934013

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