Article ID: 935772 - Last Review: February 25, 2009 - Revision: 3.0

After you upgrade to WDS, an ACPI Multiprocessor image does not appear in the menu of operating system images when you start a PXE client that uses an ACPI Uniprocessor computer HAL

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SYMPTOMS

You upgrade a Remote Installation Service (RIS) server to use Windows Deployment Services (WDS). However, images that are based on an ACPI Uniprocessor (ACPI APIC UP) Hardware Abstraction Layer (HAL) are not available. These images are not available when you start a Pre-Boot execution (PXE) client WDS boot image on an ACPI Multiprocessor (ACPI APIC MP) computer.

This problem occurs when the multiprocessor computer is running Windows Server 2003, Windows Vista, Windows XP, or Microsoft Windows 2000.

CAUSE

Windows Imaging format (WIM) images are displayed to the user based on the HAL type of the client computer. Therefore, only WIM images that exactly match the HAL type of the client computer are displayed in the menu of operating system images. In RIS, ACPI Multiprocessor (ACPI APIC MP) images appear when you start a PXE client that uses an ACPI Uniprocessor (ACPI APIC UP) computer HAL. However, in WDS, the behavior differs from the behavior in RIS.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Microsoft Windows Server 2008 to be installed on the computer.

Restart Requirement

You have to restart the computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2008, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Wdsclient.dll6.0.6001.22383255,48820-Feb-200909:59x86
Windows Server 2008, X64-based versions
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File nameFile versionFile sizeDateTimePlatform
Wdsclient.dll6.0.6001.22383274,94420-Feb-200911:40x64
Windows Server 2008, IA64 version
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File nameFile versionFile sizeDateTimePlatform
Wdsclient.dll6.0.6001.22383563,71220-Feb-200910:16IA-64

WORKAROUND

To work around this problem, create an operating system image for each computer HAL type that is present in your environment. Or, apply a specific Wdsclientunattend.xml file to each client computer.

Each Wdsclientunattend.xml file must specify the image to apply to each client computer. You can create the Wdsclientunattend.xml file by using the Windows System Image Manager (WSIM) tool. WSIM is included in the Windows Automated Installation Kit (AIK). For more information, download the "Deploying and Managing the Windows Deployment Services Update on Windows Server 2003" guide. To do this, visit the following Microsoft Web site:
http://go.microsoft.com/fwlink/?LinkId=81031 (http://go.microsoft.com/fwlink/?LinkId=81031)

MORE INFORMATION

After you apply hotfix 937333, update a Setup binary file in image 2 of the Boot.wim file. To do this, follow these steps.

Note Image 2 is a Setup Windows Preinstallation Environment (Windows PE) image.
  1. On the WDS server, install the Windows OEM Preinstallation Kit (OPK) tool set or the Windows Automated Installation Kit (AIK) tool set.
  2. Extract the CAB file (Windows6.0-KBnnnnnn-arch.cab) to a temporary folder. To do this, follow these steps:
    1. Click Start, click Run, type cmd, and then click OK.
    2. At the command prompt, type the following command, and then press ENTER:
      Expand.exe CabFilePath -F:* TempFolderPath
      Note CabFilePath represents the path of the CAB file. TempFolderPath represents the path of the temporary folder.

      If you receive an error message when you run this command, use the Expand.exe tool to extract the files. This tool is included in the Windows OPK and in the Windows AIK.
  3. Disable the startup image to make it unavailable for download. To do this, type the following command at the command prompt, and then press ENTER:
    wdsutil.exe /set-image /image:ImageName /imagetype:boot /architecture:{x86|x64|ia64} /enabled:no
    Note ImageName represents the name of the startup image.
  4. Export the startup image from the WDS server. To do this, type the following command at the command prompt, and then press ENTER:
    wdsutil.exe /export-image /image:ImageName /imagetype:boot /architecture:{x86|x64|ia64} /destinationimage /filepath:BootWimPath
    Note BootWimPath represents the path of the Boot.wim file.
  5. Mount the "Windows Server 2008 Setup (x86)" image or the "Windows Server 2008 Setup (x64)" image (index 2) of the Boot.wim file for read access and for write access. To do this, type the following command at the command prompt, and then press ENTER:
    imagex.exe /mountrw BootWimPath 2 MountLocation
    Note MountLocation represents the location where you want to mount the index 2 image. For more information about how to mount an image and about how to use the ImageX.exe tool, see the documentation in the Windows Vista OPK.
  6. Copy the Wdsclient.dll file from the temporary folder that was specified in step 2 to the source folder in the location at which you mounted the index 2 image.
  7. Unmount the Boot.wim file, and then commit all changes. To do this, type the following command at the command prompt, and then press ENTER:
    imagex.exe /commit /unmount MountLocation
  8. Add the Boot.wim file back to the WDS server. To do this, type the following command at the command prompt, and then press ENTER:
    wdsutil.exe /replace-image /image:ImageName /imagetype:boot /architecture:{x86|x64|ia64} /replacementimage /imagefile:BootWimPath
  9. Delete any folders that were created in step 2 and in step 5.

APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008
Keywords: 
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