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A networked printer that is hosted on a computer that is running Windows 2000 with Service Pack 4 may not work correctly on a client computer that is running a 64-bit version of Windows Vista

Article ID:936556
Last Review:May 2, 2007
Revision:2.0

SYMPTOMS

Consider the following scenario. A computer that is running a 64-bit version of Windows Vista uses the "Point and Print" feature to connect to a networked printer. The networked printer is hosted on a computer that is running Microsoft Windows 2000 Service Pack 4 (SP4).

In this scenario, the Windows Vista-based client computer does not correctly receive updated registry information for the printer. For example, if the printer driver data for the shared printer is changed on the server, the driver is not upgraded on the client. Because of this problem, the printer may not work correctly.

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CAUSE

This problem occurs because the server does not correctly synchronize information in the following registry subkey with a client computer that is running a 64-bit version of Windows Vista:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers\<Printer_Name>\PrinterDriverData
Therefore, the client computer does not correctly receive updated information about the printer. For example, if the configuration data for the printer driver changes on the server, these changes are not copied to the client computer.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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APPLIES TO
Windows Vista Home Basic 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Ultimate 64-bit Edition
Windows Vista Business 64-bit Edition
Windows Vista Enterprise 64-bit Edition
Microsoft Windows 2000 Professional Edition
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Datacenter Server

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Keywords: 
kbprb kbexpertiseinter kbtshoot kbbug KB936556

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