Article ID: 940523 - Last Review: November 26, 2007 - Revision: 3.2

A printer driver installation fails, or the printer does not work correctly when you use the Add Printer Driver wizard to update the driver in Windows Vista

Expand all | Collapse all

SYMPTOMS

When you use the Add Printer Driver wizard to update a printer driver in Windows Vista, the driver installation fails. Or, the printer does not work correctly.

CAUSE

This problem may occur if one of the following conditions is true:
  • You run the Add Printer Driver wizard while the HTML Help for the printer is open.

    Note You can avoid this problem by closing the HTML Help for the printer before you try to update the printer driver.
  • You run the Add Printer Driver wizard, and then you click the "x" button to close the wizard. Then you try to update the printer driver. In this scenario, the HTML Help is still locked, even though the HTML Help has been closed. Therefore, the driver setup program cannot update the HTML Help files.
  • Configuration files for the printer are installed on the computer. However, the files are not included in the printer driver.
  • A file in the driver update package has the same name and the same path as a file that is already on the computer. The previously installed file cannot be overwritten. Therefore, the driver update installation is incomplete.

WORKAROUND

To work around this problem, use one of the following methods.

Method 1: Close all programs that might be using the printer driver, and then run the Add Printer Driver wizard again
  1. Close all programs that might be using the printer driver.
  2. Click Start
    Collapse this imageExpand this image
     Start button
    , type printers in the Start Search box, and then click printers in the Programs list.
  3. Right-click the printer, point to Run as administrator, and then click Properties.

    Collapse this imageExpand this image
     User Account Control permission
    If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
  4. Click the Advanced tab.
  5. Click New Driver.
  6. Follow the steps in the Add Printer Driver wizard.
Method 2: Log off, log back on, and then run the Add Printer Driver wizard again
  1. Log off the computer, and then log back on.
  2. Click Start
    Collapse this imageExpand this image
     Start button
    , type printers in the Start Search box, and then click printers in the Programs list.
  3. Right-click the printer, point to Run as administrator, and then click Properties.

    Collapse this imageExpand this image
     User Account Control permission
    If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
  4. Click the Advanced tab.
  5. Click New Driver.
  6. Follow the steps in the Add Printer Driver wizard.
If method 2 does not resolve the problem, go to Method 3.

Method 3: Remove the printer driver, and then run the Add Printer Driver wizard
  1. Log off the computer, and then log back on.
  2. Click Start
    Collapse this imageExpand this image
     Start button
    , type printers in the Start Search box, and then click printers in the Programs list.
  3. Right-click the printer, point to Run as administrator, and then click Server Properties. Or, press ALT, click Run as Administrator on the File menu, and then click Server Properties.

    Collapse this imageExpand this image
     User Account Control permission
    If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
  4. Click the Drivers tab.
  5. Click the printer that you want to update, and then click Remove.
  6. Click Add.
  7. Follow the steps in the Add Printer Driver wizard.

    Note When you try to update a printer driver, the printer objects that use the printer driver may already exist. In this scenario, to successfully update the printer driver, you may have to remove the printer objects from history that previously corresponded to the printer driver before you update the printer driver. If you do not remove the printer objects from history first, the printer driver may not be updated successfully. The printer object is shown as a printer icon on the printer folder. To completely remove a printer object, you must delete the printer folder that includes the printer icon.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
Keywords: 
kbharmony kbtshoot kbexpertiseinter kbddk KB940523
 

Article Translations