Help and Support

Article ID: 946481 - Last Review: September 9, 2008 - Revision: 6.0

Error message when you try to connect to an ad hoc connection from a Windows Vista-based computer: "Windows cannot connect to <Network Name>"

Expand all | Collapse all

SYMPTOMS

Consider the following scenario. You use a local area network (WLAN) device on a computer that is running Windows Vista ("Computer A") to establish a computer-to-computer (ad hoc) connection that has WPA2 specified. You have another Windows Vista-based computer ("Computer B") that also has a wireless adapter installed.

In this scenario, when you try to establish an ad hoc connection from Computer B, you may receive the following error message:
Windows cannot connect to Network Name
Note In this error message, Network Name is a placeholder for the name of the ad hoc connection.

Alternatively, you may not receive this error message sometimes. However, you may notice the following symptoms:
  • After Computer A is resumed, Computer A is always pending for Computer B to connect to Computer A.
  • The Ping command does not work, even though the status for both computers is “CONNECTED."

CAUSE

This problem occurs because Windows Vista does not automatically recover when a WPA2 ad hoc network connection times out. A time-out may occur if one of the following conditions is true:
  • Windows Vista detects no activity.
  • There is a busy network traffic load.
  • The network device drivers are outdated.

WORKAROUND

Note Microsoft has released Windows Vista Service Pack 1 (SP1). This service pack includes improvements in WLAN reliability. Before you troubleshoot a WLAN issue, you should verify that Windows Vista SP1 is installed on the Windows Vista-based computer. For more information about how to obtain Windows Vista SP1, click the following article number to view the article in the Microsoft Knowledge Base:
935791  (http://support.microsoft.com/kb/935791/ ) How to obtain the latest Windows Vista service pack

Workaround 1

To work around this problem, set up another new Ad Hoc profile.

Workaround 2

To work around this problem, reconnect the ad hoc connection on both Computer and Computer B.

RESOLUTION

To resolve this problem, improve the reliability of Windows Vista in a WPA2 ad hoc environment. To do this, follow these steps:
  1. Install the latest WLAN device drivers by using Windows Update. To do this, follow these steps:
    1. Click Start
      Collapse this imageExpand this image
      Start button
      , type Windows Update in the Start Search box, and then press ENTER.
    2. Click Check for updates.
    3. After the scan is complete, click View Available Updates.
    4. Select all updates that refer to networking drivers or to wireless drivers.
    5. Click Install Updates.
  2. Visit the support Web site of the driver manufacturer to obtain the latest network device drivers.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
Keywords: 
kbexpertiseinter kbtshoot kbprb KB946481

Article Translations