Article ID: 947784 - Last Review: February 19, 2008 - Revision: 1.1

Customized information is lost on a Windows Vista-based computer if you restart the computer while you are running the OOBE Wizard for the first time

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SYMPTOMS

Consider the following scenario
  • You purchase a computer that has Windows Vista preinstalled.
  • You run the Out of Box Experience (OOBE) Wizard during the setup process for the first time.
  • You restart the computer while the wizard is running.
In this scenario, you discover that certain customized information is lost after the OOBE Wizard has finished running.

CAUSE

This issue occurs because the oobeSystem pass in the Unattend.xml file is incorrectly marked as completed before the OOBE Wizard actually runs.

If you shut down the computer for any reason while you are running the OOBE Wizard, the OOBE Wizard starts again after you restart the computer. However, the OOBE Wizard does not process the oobeSystem pass again because the waspassprocessed field is incorrectly marked as true, or completed. Therefore, certain customized information is lost.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
X86_ce4419fa382e80c0bae2f08bf87bf09e_31bf3856ad364e35_6.0.6000.20760_none_dcc865699bdbb4d1.manifestNot Applicable70325-Jan-200818:14Not Applicable
X86_microsoft-windows-setup-component_31bf3856ad364e35_6.0.6000.20760_none_308efcebc969ff16.manifestNot Applicable27,02025-Jan-200805:22Not Applicable
Actionqueue.dll6.0.6000.20760167,42425-Jan-200805:02x86
Audit.exe6.0.6000.2076052,22425-Jan-200802:38x86
Diager.dll6.0.6000.2076031,23225-Jan-200805:06x86
Diagnostic.dll6.0.6000.20760121,85625-Jan-200805:06x86
Oobeldr.exe6.0.6000.2076042,49625-Jan-200802:38x86
Setup.cfgNot Applicable1,57213-Dec-200720:23Not Applicable
Setup.exe6.0.6000.20760194,10425-Jan-200805:06x86
Spprgrss.dll6.0.6000.2076052,73625-Jan-200805:06x86
Sysprep.exe6.0.6000.2076094,20825-Jan-200802:39x86
W32uiimg.dll6.0.6000.207602,928,64025-Jan-200805:06x86
W32uires.dll6.0.6000.20760260,09625-Jan-200805:06x86
Wdsutil.dll6.0.6000.2076047,10425-Jan-200805:06x86
Win32ui.dll6.0.6000.20760394,24025-Jan-200805:06x86
Windeploy.exe6.0.6000.2076041,47225-Jan-200802:39x86
Winsetup.dll6.0.6000.207601,375,74425-Jan-200805:06x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_7037da76aff7bcbf72247758bc425f82_31bf3856ad364e35_6.0.6000.20760_none_be8b483ad0d9b960.manifestNot Applicable1,05425-Jan-200818:14Not Applicable
Amd64_microsoft-windows-setup-component_31bf3856ad364e35_6.0.6000.20760_none_8cad986f81c7704c.manifestNot Applicable27,08625-Jan-200805:44Not Applicable
X86_microsoft-windows-setup-component_31bf3856ad364e35_6.0.6000.20760_none_308efcebc969ff16.manifestNot Applicable27,02025-Jan-200805:22Not Applicable
Actionqueue.dll6.0.6000.20760200,70425-Jan-200805:24x64
Audit.exe6.0.6000.2076062,46425-Jan-200803:04x64
Diager.dll6.0.6000.2076038,40025-Jan-200805:27x64
Diagnostic.dll6.0.6000.20760146,43225-Jan-200805:27x64
Oobeldr.exe6.0.6000.2076048,12825-Jan-200803:04x64
Setup.cfgNot Applicable1,57214-Dec-200721:59Not Applicable
Setup.exe6.0.6000.20760211,51225-Jan-200805:27x64
Spprgrss.dll6.0.6000.2076053,24825-Jan-200805:27x64
Sysprep.exe6.0.6000.20760108,03225-Jan-200803:04x64
W32uiimg.dll6.0.6000.207602,928,12825-Jan-200801:04x64
W32uires.dll6.0.6000.20760259,58425-Jan-200801:04x64
Wdsutil.dll6.0.6000.2076056,32025-Jan-200805:27x64
Win32ui.dll6.0.6000.20760543,23225-Jan-200805:27x64
Windeploy.exe6.0.6000.2076045,56825-Jan-200803:04x64
Winsetup.dll6.0.6000.207601,747,45625-Jan-200805:27x64
Actionqueue.dll6.0.6000.20760167,42425-Jan-200805:02x86
Audit.exe6.0.6000.2076052,22425-Jan-200802:38x86
Diager.dll6.0.6000.2076031,23225-Jan-200805:06x86
Diagnostic.dll6.0.6000.20760121,85625-Jan-200805:06x86
Oobeldr.exe6.0.6000.2076042,49625-Jan-200802:38x86
Setup.cfgNot Applicable1,57213-Dec-200720:23Not Applicable
Setup.exe6.0.6000.20760194,10425-Jan-200805:06x86
Spprgrss.dll6.0.6000.2076052,73625-Jan-200805:06x86
Sysprep.exe6.0.6000.2076094,20825-Jan-200802:39x86
W32uiimg.dll6.0.6000.207602,928,64025-Jan-200805:06x86
W32uires.dll6.0.6000.20760260,09625-Jan-200805:06x86
Wdsutil.dll6.0.6000.2076047,10425-Jan-200805:06x86
Win32ui.dll6.0.6000.20760394,24025-Jan-200805:06x86
Windeploy.exe6.0.6000.2076041,47225-Jan-200802:39x86
Winsetup.dll6.0.6000.207601,375,74425-Jan-200805:06x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business 64-bit Edition
Keywords: 
kbautohotfix kbexpertisebeginner kbexpertiseinter kbhotfixserver kbqfe KB947784
 

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