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When you run an .exe file on a Windows Vista-based computer, the file may start a different program

Article ID:950505
Last Review:April 4, 2008
Revision:1.0

SYMPTOMS

When you run an .exe file on a Windows Vista-based computer, the file may start a different program. Additionally, the icon for the .exe file may not appear as expected. You may also receive additional errors from the .exe file or from the program that starts.

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CAUSE

This problem occurs if one or more of the following conditions are true:
The file association of the .exe file has been changed to another default program.
The registry subkey setting for the file association is corrupted.

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RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows
To resolve this problem, reset the registry subkey for the file association of the .exe file back to the default setting. To do this, follow these steps:
1. Click Startthe Start button, type notepad in the Start Search box, and then press ENTER.
2.Paste the following text into Notepad:
Windows Registry Editor Version 6.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\OpenWithList]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\OpenWithProgids]
"exefile"=hex(0):
3. On the File menu, click Save as.
4.Select All Files in the Save as type list, and then type Exe.reg in the File name box.
5. Click Save, and then close Notepad.
6. Double-click the Exe.reg file.
If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
7. Click Yes, and then click OK in response to the registry prompts.
8. Log off from your account. Then, log back onto your account.
Note You may have to restart the computer to restore the program icons to their original appearance.

Note After the problem is resolved, delete the Exe.reg file so that it is not mistakenly added back to the registry at a later date.

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APPLIES TO
Windows Vista Business
Windows Vista Enterprise
Windows Vista Home Basic
Windows Vista Home Premium
Windows Vista Starter
Windows Vista Ultimate
Windows Vista Business 64-bit Edition
Windows Vista Enterprise 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Ultimate 64-bit Edition

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Keywords: 
kbexpertiseinter kbtshoot kbprb KB950505

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