Help and Support
 

powered byLive Search
Hotfix Download Available

When you use Windows Desktop Search (WDS) or Instant Search to perform a search on traditional Chinese characters on a Windows Vista-based computer, the search results are incorrect

Article ID:951499
Last Review:May 5, 2008
Revision:1.1
On This Page

SYMPTOMS

Consider the following scenario:
You are running a Windows Vista-based computer.
You use Windows Desktop Search (WDS) or Instant Search to perform a search on some traditional Chinese characters.
In this scenario, documents that are known to contain the traditional Chinese characters are not returned in the search results.

For example, when you perform a search by using a person's full name in WDS or in Instant Search, documents that contain the name are returned in the search results. However, when you perform a search by using the person's first name, no documents are returned.

Back to the top

CAUSE

This issue occurs because the word breaks in traditional Chinese names are not formatted and displayed correctly. Therefore, you may be unable to find the names and characters in question, even though they do actually appear in the text that you search.

Back to the top

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Package_1_for_kb951499~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,97216-Apr-200817:48Not Applicable
Package_2_for_kb951499~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,81016-Apr-200817:48Not Applicable
Package_3_for_kb951499~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,81016-Apr-200817:48Not Applicable
Package_for_kb951499_client_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42516-Apr-200817:48Not Applicable
Package_for_kb951499_client_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,36716-Apr-200817:48Not Applicable
Package_for_kb951499_client~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71116-Apr-200817:48Not Applicable
Package_for_kb951499_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42516-Apr-200817:48Not Applicable
Package_for_kb951499_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,43016-Apr-200817:48Not Applicable
Update.mumNot Applicable2,08416-Apr-200817:48Not Applicable
X86_8066a90ee68c28e6f6261b0307c7f124_31bf3856ad364e35_6.0.6000.20815_none_ed959d6110c044e9.manifestNot Applicable72516-Apr-200817:48Not Applicable
X86_c372f1e0607859b54e542dc2f33e86dc_31bf3856ad364e35_6.0.6001.22159_none_44aba0bcf705bf1f.manifestNot Applicable72516-Apr-200817:48Not Applicable
X86_microsoft-windows-w..-chinesetraditional_31bf3856ad364e35_6.0.6000.20815_none_ec49de2c71efb366.manifestNot Applicable8,21816-Apr-200806:47Not Applicable
X86_microsoft-windows-w..-chinesetraditional_31bf3856ad364e35_6.0.6001.22159_none_ee08dc646f331c50.manifestNot Applicable8,21816-Apr-200806:59Not Applicable
Chtbrkr.dll6.0.6000.208156,103,04016-Apr-200805:50x86
Noise.chtNot Applicable1,69613-Dec-200719:53Not Applicable
Chtbrkr.dll6.0.6001.221596,103,04016-Apr-200805:48x86
Noise.chtNot Applicable1,69618-Dec-200721:08Not Applicable
Windows Vista, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Amd64_b5539b003292617bce51614fe8961a7f_31bf3856ad364e35_6.0.6001.22159_none_688ecf559f65908b.manifestNot Applicable1,09816-Apr-200817:48Not Applicable
Amd64_c483bc85b77d1c42bf854d855bca78e0_31bf3856ad364e35_6.0.6000.20815_none_e3004b2f1ccd45ea.manifestNot Applicable1,09816-Apr-200817:48Not Applicable
Amd64_microsoft-windows-w..-chinesetraditional_31bf3856ad364e35_6.0.6000.20815_none_486879b02a4d249c.manifestNot Applicable8,23216-Apr-200807:09Not Applicable
Amd64_microsoft-windows-w..-chinesetraditional_31bf3856ad364e35_6.0.6001.22159_none_4a2777e827908d86.manifestNot Applicable8,23216-Apr-200809:09Not Applicable
Package_1_for_kb951499~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable2,22716-Apr-200817:48Not Applicable
Package_2_for_kb951499~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable2,06316-Apr-200817:48Not Applicable
Package_3_for_kb951499~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable2,06316-Apr-200817:48Not Applicable
Package_for_kb951499_client_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43316-Apr-200817:48Not Applicable
Package_for_kb951499_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,37516-Apr-200817:48Not Applicable
Package_for_kb951499_client~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72116-Apr-200817:48Not Applicable
Package_for_kb951499_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43316-Apr-200817:48Not Applicable
Package_for_kb951499_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43816-Apr-200817:48Not Applicable
Update.mumNot Applicable2,09816-Apr-200817:48Not Applicable
Chtbrkr.dll6.0.6000.208156,100,48016-Apr-200806:07x64
Noise.chtNot Applicable1,69614-Dec-200721:35Not Applicable
Chtbrkr.dll6.0.6001.221596,100,48016-Apr-200808:10x64
Noise.chtNot Applicable1,69618-Dec-200721:08Not Applicable
Windows Vista, IA-64-based versions
File nameFile versionFile sizeDateTimePlatform
Ia64_bb17c0407ad3d0882a382c53f4da2a8f_31bf3856ad364e35_6.0.6001.22159_none_857d1f1ac112c4b0.manifestNot Applicable1,09616-Apr-200817:48Not Applicable
Ia64_microsoft-windows-w..-chinesetraditional_31bf3856ad364e35_6.0.6001.22159_none_ee0a805a6f31254c.manifestNot Applicable8,22516-Apr-200814:16Not Applicable
Package_1_for_kb951499~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable2,05816-Apr-200817:48Not Applicable
Package_for_kb951499_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,42916-Apr-200817:48Not Applicable
Package_for_kb951499_server~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,43416-Apr-200817:48Not Applicable
Update.mumNot Applicable1,42516-Apr-200817:48Not Applicable
Chtbrkr.dll6.0.6001.221596,167,04016-Apr-200808:05IA-64
Noise.chtNot Applicable1,69618-Dec-200721:08Not Applicable

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

For more information about Windows Desktop Search, visit the following Microsoft Web site:
http://www.microsoft.com/windows/products/winfamily/desktopsearch/choose/windowsdesktopsearch.mspx (http://www.microsoft.com/windows/products/winfamily/desktopsearch/choose/windowsdesktopsearch.mspx)
For more information about Instant Search, visit the following Microsoft Web site:
http://www.microsoft.com/uk/windows/products/windowsvista/features/details/instantsearch.mspx (http://www.microsoft.com/uk/windows/products/windowsvista/features/details/instantsearch.mspx)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

Back to the top


APPLIES TO
Windows Vista Enterprise 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Ultimate 64-bit Edition
Windows Vista Business
Windows Vista Business 64-bit Edition
Windows Vista Enterprise
Windows Vista Home Basic
Windows Vista Home Premium
Windows Vista Ultimate

Back to the top

Keywords: 
kbautohotfix kbexpertisebeginner kbfix kbqfe kbhotfixserver KB951499

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.