Help and Support

Article ID: 952572 - Last Review: May 29, 2008 - Revision: 2.0

The Message Queuing service does not start when you run Windows Vista in Workgroup mode after you uninstall Windows Vista SP1

Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • You run the release version of Windows Vista in Workgroup mode.
  • You install Windows Vista Service Pack 1 (SP1).
  • You uninstall Windows Vista SP1.
  • You run Windows Vista in Workgroup mode again.
In this scenario, the Microsoft Message Queuing (also known as MSMQ) service does not start. Additionally, an event is logged to indicate that the notify_queue$ queue is not found.

CAUSE

This issue occurs because the notify_queue$ queue is deleted if Windows Vista runs in Workgroup mode after you install Windows Vista SP1 and then start the Message Queuing service.

RESOLUTION

To resolve this issue, follow these steps:
  1. Click Start, type notepad in the Start Search box, right-click Notepad in the Programs list, and then click Run as administrator.

    If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
  2. On the File menu, click Open.
  3. In the Open window, locate and then double-click the following file:
    %windir%\system32\msmq\storage\lqs\00000002.990736e8
  4. Open another untitled Notepad instance by using the method that step 1 describes.
  5. Copy all the content from the 00000002.990736e8 file to the untitled Notepad instance.
  6. Locate the following entries in the untitled Notepad instance:
    • Label=private$\admin_queue$
    • Type=00000000-0000-0000-0000-000000000000
    • QueueName=\private$\admin_queue$
  7. Modify the entries to the following:
    • Label=private$\notify_queue$
    • Type=00000000-0000-0000-0000-000000000000
    • QueueName=\private$\notify_queue$
  8. In the untitled Notepad instance, click Save As on the File menu.
  9. In the Save As window, select All Files (*.*) in the Save as type list, type 000000003.6AB7C4B8 in the File name box, and then save the file to the following location:
    %windir%\system32\msmq\storage\lqs\
  10. Restart the Message Queuing service.

APPLIES TO
  • Microsoft Message Queuing 4.0
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Ultimate
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Home Basic
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium
  • Windows Vista Home Premium 64-bit Edition
Keywords: 
kbexpertiseadvanced kbtshoot kbprb KB952572

Article Translations