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Article ID: 954070 - Last Review: July 1, 2008 - Revision: 1.0

Message in the Digital Signer field in Device Manager after you install a signed driver on a Windows Vista-based computer: "Not digitally signed"

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SYMPTOMS

Consider the following scenario:
  • On a Windows Vista-based computer, you install a signed driver.
  • You open Device Manager, and then you click the Driver Details button on the Driver tab.
In this scenario, the Digital Signer field for the device displays the following status message:
Not digitally signed
However, when you right-click the properties of the device on the main Device Manager tab, a message is displayed that states that the driver is signed.

CAUSE

This problem occurs if the developer uses a customer-defined GUID for a class name that is selected from a Microsoft-defined list of classes (such as BLUETOOTH) in the .inf file.

Note If "Not digitally signed" is displayed in the Digital Signer field in the device properties in Device Manager, this may not be caused by the same issue that is described in the "Symptoms" section. Instead, your driver may not have been signed by the software publisher. If this is the case, you may be able to obtain a signed driver from the software publisher.

For more information about signed drivers in Windows Vista and about the steps to take if you do not have a signed driver, visit the following Microsoft Web site:
http://windowshelp.microsoft.com/Windows/en-US/help/5622d7d6-531b-4e76-be48-0059d38339c41033.mspx (http://windowshelp.microsoft.com/Windows/en-US/help/5622d7d6-531b-4e76-be48-0059d38339c41033.mspx)

WORKAROUND

To work around this issue, use one of the following methods, as appropriate for your situation.

Workarounds for end-users

Method 1

If "Not digitally signed” is displayed in the Digital Signer field in Device Manager because of the issue that is described in the "Cause" section, use the Update Driver command in Device Manager to update the driver. To do this, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , type devmgmt.msc in the Start Search box, and then click devmgmt.

    Collapse this imageExpand this image
    User Account Control permission
    If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
  2. In Device Manager, double-click the device that is not digitally signed.
  3. Click the Driver tab, and then click Update Driver.
  4. Click Browse my computer for driver software, and then click Let me pick from a list of device drivers on my computer.
  5. Click the driver that you want to update, and then click Next. Do not click Have Disk.
  6. Click Close.

Method 2

Install the driver before you connect the hardware device to the computer.

Workaround for driver developers

If "Not digitally signed” is displayed in the Digital Signer field in Device Manager because of the issue that is described in the "Cause" section, change the .inf file to use the Microsoft-assigned GUID for the Microsoft-defined class name. For example, if the Microsoft-defined class name of BLUETOOTH is used, use the already defined GUID for BLUETOOTH, and then re-sign the driver.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about drivers, visit the following Microsoft Web site:
http://windowshelp.microsoft.com/Windows/en-US/Help/703e99fd-96a7-4063-98ee-fce4a7539a251033.mspx (http://windowshelp.microsoft.com/Windows/en-US/Help/703e99fd-96a7-4063-98ee-fce4a7539a251033.mspx)
For more information about how to update a driver for hardware that is not working correctly, visit the following Microsoft Web site:
http://windowshelp.microsoft.com/Windows/en-US/Help/b3c6477e-1111-4b9f-a52a-fffdc51e9c901033.mspx (http://windowshelp.microsoft.com/Windows/en-US/Help/b3c6477e-1111-4b9f-a52a-fffdc51e9c901033.mspx)

APPLIES TO
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Keywords: 
kb3rdpartyhardware kbtshoot kbexpertiseinter kbprb KB954070

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