Article ID: 954377 - Last Review: August 21, 2008 - Revision: 1.1

You cannot view all the print servers in the Print Management console on a Windows Vista-based computer

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SYMPTOMS

When you view the print server information for the print servers in the Print Management console on a Windows Vista-based computer, you notice that all the print servers are not displayed in the Print Management console. You may also experience other issues that prevent you from viewing the complete information for a print server. For example, the print queue information may not be available.

Note You may also experience this issue in the Print Management console that is running on a Windows Server 2003 R2-based or Windows XP Professional Edition-based computer.

CAUSE

This issue occurs because the Print Management console can only connect to 10 print servers at the same time on a Windows Vista-based computer. If you add more than 10 print servers to the Print Management console, and you restart the Print Spooler service, you may notice one or more of the following symptoms:
  • The order of the print servers that are displayed in the Print Management console changes.
  • The Print Management console displays different print servers.

STATUS

This behavior is by design.

MORE INFORMATION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
To troubleshoot general issues that are related to print servers, use one or more of the following options:
  • Use Windows Explorer to check whether you can connect to the network printers.
  • Make sure that the File and Printer Sharing check box is selected in the Exceptions tab of the Windows Firewall dialog box on all print server computers.
  • Make sure that the users who manage the print server computers are members of the Domain Admins group.
  • Make sure that trust relationships are set between the domains if the print server computers are in different domains.
  • Make sure that the following registry entry is added to the registry for all the print server computers:
    Registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print
    Registry entry: MaxRpcSize
    Registry type: REG_DWORD
    Registry value: 400000

APPLIES TO
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
Keywords: 
kbregistry kbexpertiseinter kbtshoot kbprb KB954377
 

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