Scanning using a scanner may cause a TWAIN aware application to hang

This article provides a resolution for the issue that scanning using a scanner may cause a TWAIN aware application to hang.

Applies to:   Windows 7 Service Pack 1
Original KB number:   982436

Source: Microsoft Support

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Symptoms

When a 32-bit TWAIN aware application scans using a WIA driver on a 64-bit Windows Vista or Windows 7 system, the TWAIN application may stop responding.

Cause

If you leave the scan dialog open for about 10 minutes before you push the [Scan] button, the message used to transfer the scanned image from the WIA driver to the TWAIN application is not sent to the TWAIN application.

Resolution

This problem can be avoided by doing either of the followings:

  • Scan image soon after you open the scan dialog.

  • Use a WIA aware application, not a TWAIN aware application.

More information

This behavior is by design.

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