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The Microsoft Distributed Transaction Service Does Not Start and Error 3221229584 Is Logged

Article ID:205069
Last Review:November 1, 2006
Revision:2.2
This article was previously published under Q205069
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SYMPTOMS

The Microsoft Distributed Transaction service (MSDTC) does not start and the following event ID is logged:
Event ID : 7024
Source : Service Control Manager
Description: The MSDTC service terminated with service specific error 3221229584.

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CAUSE

This error indicates that the MSDTC service is unable to locate the MSDTC log file when it tries to start.

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RESOLUTION

Windows NT 4.0

To resolve this behavior on a Windows NT 4.0-based computer:
1.From a command prompt, type dac to start the MSDTC Administrator console.
2.Click the Advanced tab, and then verify that the drive and the location for the MSDTC log is correct.
3.Click Reset the log to reset the log.

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Windows 2000

To resolve this behavior on a Windows 2000-based computer, use one of the following methods, as appropriate for your situation.

Method 1

1.Create a new Microsoft Management Console (MMC):
a. Click Start, click Run, type mmc, and then click OK.
b. When MMC opens, on the Console menu, click Add/Remove Snap-in, and then click Add.
c. Click Component Services, click Add, and then close the window.
d. Click OK on the Add/Remove Snap-in dialog box.
2.Expand Component Services, and then in the Computers node, right-click the computer that is generating the error, which is usually My Computer, and then click Properties.
3.On the Advanced tab, the location of the log file, Msdtc.log, should be %SystemRoot%\System32\Dtclog. If this is not the location that is indicated, use the Drive and Directory controls to specify this location.
4.Click Reset Log.
5.Start the MSDTC service.

Method 2

1.Rename the %SystemRoot%\System32\Dtclog folder to Dtclog.old.
2.Create a new Dtclog folder in the same location (%SystemRoot%\System32\Dtclog).
3.At a command prompt, type the following, and then press ENTER:
MSDTC -resetlog
4.Start the MSDTC service.

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STATUS

This behavior is by design.

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MORE INFORMATION

For more information about Microsoft Transaction Server, refer to the following Microsoft Web site:
http://support.microsoft.com/support/transaction (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fsupport%2ftransaction)

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APPLIES TO
Microsoft Windows 2000 Server
Microsoft Windows NT Server 4.0 Standard Edition

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Keywords: 
kbenv kberrmsg kbprb KB205069

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