You receive a "0x00138f Cluster resource not found" error message when you try to join a second node to a Windows Server 2003 cluster

Article translations Article translations
Article ID: 909968 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

When you try to join a second node to a Microsoft Windows Server 2003 cluster, you receive the following error message:
0x00138f Cluster resource not found

CAUSE

This issue occurs in a complex storage area network (SAN) configuration.

This issue is caused by an interaction between two technologies: the new Cluster Setup Wizard and the SAN configuration. The new Cluster Setup Wizard contains heuristics to verify that all cluster nodes have access to the same disks. To perform this verification, the wizard determines whether all cluster nodes recognize the disks that use the same target ID (TID) and the same logical unit number (LUN). Typically, the wizard can successfully perform this verification when a cluster shared-disk array is configured correctly. However, with a complex SAN configuration, the wizard may not be able to perform this verification.

In a complex SAN environment, the "0x00138f Cluster resource not found" error message may indicate that the same set of disks have been detected on different TIDs and on different LUNs by individual nodes. In this scenario, Setup matches the resource name to verify that all cluster nodes have access to the same disk. Then, the setup process continues.

Note This issue may also occur when you run the new Cluster Setup Wizard for the first time when you create the first cluster node.

WORKAROUND

To work around this issue, let the Cluster Setup Wizard process continue. The second node does eventually join the cluster.

Note If you are running the Cluster Setup Wizard for the first time when you create the first cluster node, let the cluster be created together with the local quorum. Add a physical disk resource by using the Cluster Administrator. Then, change the quorum location to the new disk by using the Cluster Properties dialog box. After you do this, add the disk that you originally designated for the quorum by using Cluster Administrator. Then, move the quorum back to the correct disk. When the new quorum is online, take the old local quorum resource offline and delete it.

MORE INFORMATION

A SAN that has multiple switches between the nodes and the storage component is an example of a complex storage solution. Because the cluster nodes do not require that the same path for any particular disk always be used, nodes may enumerate the disks by using different IDs. For example, node A may enumerate disk 1 as follows:
LUN 1 TID 1
However, because node B can be connected to a separate switch and to a separate controller in the SAN and still enumerate the same disk, the disk may be enumerated as follows:
LUN 2 TID 3
You may also receive the error that is mentioned in the "Symptoms" section if you use multi-pathing software. You may receive the error message when the multi-pathing software runs an analysis phase where the request could go down one path. Next, the multi-pathing software runs a commit phase where the request could go down another path. Because the first "Bus / Port / TID / LUN" query and the second "Bus / Port / TID / LUN" query do not match, you may receive the error message that is mentioned in the "Symptoms" section.

Properties

Article ID: 909968 - Last Review: February 9, 2007 - Revision: 3.3
APPLIES TO
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Keywords: 
kbexpertiseadvanced kbtshoot kberrmsg KB909968

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com