Article ID: 936655 - Last Review: October 11, 2007 - Revision: 1.6

A Citrix process uses 4 gigabytes (GB) of nonpaged pool memory on a Microsoft Windows Server 2003-based computer

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SYMPTOMS

On a Microsoft Windows Server 2003-based computer, when you view Windows Task Manager, you see that a Citrix process uses 4 gigabytes (GB) of nonpaged pool memory. This problem occurs when the computer is running Citrix Presentation Server.

CAUSE

This problem occurs because the Afd.sys file may charge the quota to one Citrix process after the Citrix process allocates the nonpaged pool memory. Then, the quota is returned to another Citrix process after the Citrix process frees the nonpaged pool memory. When the nonpaged pool memory is allocated and then freed repeatedly, the quota that is allocated for the second time is a negative number. On a 32-bit system, this negative number is interpreted as a second Citrix process that uses 4 GB of nonpaged pool memory.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Afd.sys5.2.3790.2928152,57602-May-200711:39x86
Windows Server 2003 with SP2, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Afd.sys5.2.3790.4072150,52802-May-200713:35x86
Windows Server 2003 with SP1, x64-based versions
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File nameFile versionFile sizeDateTimePlatform
Afd.sys5.2.3790.2928299,00802-May-200719:43x64
Windows Server 2003 with SP2, x64-based versions
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File nameFile versionFile sizeDateTimePlatform
Afd.sys5.2.3790.4072291,84002-May-200720:06x64
Windows Server 2003 with SP1, Itanium-based versions
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File nameFile versionFile sizeDateTimePlatform
Afd.sys5.2.3790.2928583,68002-May-200719:43IA-64
Windows Server 2003 with SP2, Itanium-based versions
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File nameFile versionFile sizeDateTimePlatform
Afd.sys5.2.3790.4072583,68002-May-200721:25IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Keywords: 
kbautohotfix kbexpertiseinter kbhotfixserver kbqfe KB936655
 

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