Article ID: 153685 - Last Review: October 7, 2003 - Revision: 2.0

FP: FrontPage Appears to Hang When Using Dial-Up-Adapter

This article was previously published under Q153685

For a Microsoft FrontPage 98 version of this article, see 194237  (http://support.microsoft.com/kb/194237/EN-US/ ) .
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SYMPTOMS

If you use a Dial-Up-Adapter to connect to the Internet and you are not currently connected, your computer may appear to hang (stop responding) when you use FrontPage Explorer or FrontPage TCP/IP Test.

CAUSE

If you are using DNS for name resolution, any call to the TCP/IP stack attempts to resolve to an IP address. If you are not connected to your Internet service provider, the DNS server available is not available. The computer attempts to wait until a DNS server replies.

WORKAROUND

To work around this problem, follow these steps:

  1. Find the Hosts file (located in the C:\Windows\ folder). If it does not exist, rename Hosts.sam to Hosts.
  2. Open the Hosts file in a text editor (such as Notepad), and add the following line to the end of the file
    127.0.0.1 <fqdn>
    where <fqdn> is the Fully Qualified Domain Name as specified on the DNS Configuration tab of the TCP/IP Properties tab (double-click the Network icon in Windows Control Panel). For example, if the Host is named Example and the Domain is called Microsoft.com, add the following line to the Hosts file:
    127.0.0.1 example.microsoft.com

APPLIES TO
  • Microsoft FrontPage 97 Standard Edition
  • Microsoft FrontPage 1.1 Standard Edition
Keywords: 
kbnetwork kbprb KB153685
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

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