Article ID: 155000 - Last Review: January 19, 2007 - Revision: 1.2 Error Message: Sage Cannot Be RemovedThis article was previously published under Q155000
IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, you should first make a backup copy of the
registry files (System.dat and User.dat). Both are hidden files in the
Windows folder.
SYMPTOMS
When you attempt to remove Microsoft Plus! for Windows 95, you may receive
the following error message:
Sage cannot be removed because backups are missing or the wrong
version.
Microsoft Plus! for Windows 95 Setup was not completed successfully.
CAUSE
You are attempting to uninstall System Agent from a Windows 95 OEM Service
Release 2 (OSR2) Installation.
Microsoft Plus! Setup does not remove System Agent from Windows 95 OSR2 installations. RESOLUTION
Microsoft Plus! Setup uninstalls System Agent if the backup files are
copied from a retail Windows 95 installation. If you have access to a
retail Windows 95 system, use the following steps to remove System Agent.
NOTE: The following files are required. If Microsoft Plus! is installed on the retail Windows 95 system, the following files' extension will be .w95. File sizes are listed in bytes. Windows\Scandskw.exe 4,608 Windows\System\Dskmaint.dll 189,456 Windows\Command\Scandisk.exe 134,738 File name DMF disks Non-DMF disks CD-ROM ---------------------------------------------------------- Scandskw.exe Win95_09.cab Win95_14.cab Win95_09.cab Dskmaint.dll Precopy2.cab Precopy2.cab Precopy2.cab Scandisk.exe Disk 1 Disk 1 Win95 folder
154998
(http://support.microsoft.com/kb/154998/EN-US/
)
Error Message: ScanDisk Cannot Check Drive
WARNING: Using Registry Editor incorrectly can cause serious problems that
may require you to reinstall Windows 95. Microsoft cannot guarantee that
problems resulting from the incorrect use of Registry Editor can be solved.
Use Registry Editor at your own risk.
NOTE: For information about how to edit the registry, view the Changing Keys And Values online Help topic in Registry Editor (Regedit.exe). Note that you should make a backup copy of the registry files (System.dat and User.dat) before you edit the registry. If a retail Windows 95 system is unavailable, you can prevent System Agent from loading by removing the SystemAgent string from the following registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ Uninstall\Plus! Windows\System folder: Sage.exe, Sage.vxd, Sage.dll. Program Files\Plus! folder: Sagelog.txt, Sysagent.exe Program Files\Plus!\System folder: Sage.dat, Sage.def STATUS
Microsoft has confirmed this to be a problem in Microsoft Plus! for
Windows 95 version 1.0. We are researching this problem and will post new
information here in the Microsoft Knowledge Base as it becomes available.
MORE INFORMATION
Microsoft Plus! Setup updates several system files, as well as ScanDisk,
for DriveSpace 3. Setup does not overwrite these files but rather renames
them with .w95 extensions so they can be restored.
When you install Microsoft Plus! in Windows 95 OSR2, Setup does not replace Windows 95 OSR2 system files because they are more recent. Consequently, backups that would be generated for the files are not created. The uninstall process for System Agent includes restoring the original ScanDisk files, but the uninstall process does not work with OSR2 because the backup files were not created. | Article Translations
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