Article ID: 169079 - Last Review: August 5, 2004 - Revision: 1.1 FP97: Error Message Connecting to FrontPage EditorThis article was previously published under Q169079 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986
(http://support.microsoft.com/kb/256986/EN-US/
)
Description of the Microsoft Windows Registry
On This PageSYMPTOMS
When you start FrontPage Editor from within FrontPage Explorer, you
receive the following error message:
Unable to connect to the FrontPage Editor.
Could not make connection to the FrontPage Explorer. Please try to
start the FrontPage Explorer from the Start menu or the icon in the
program group.
CAUSE
This error may result from any of the following conditions:
RESOLUTION
Start with the first method and proceed to the next method until the
problem is corrected.
Method 1: Illegal TCP/IP NameCheck the name of the computer and correct it. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:156909
(http://support.microsoft.com/kb/156909/EN-US/
)
FP: OLE Errors When Working With FrontPage
Method 2: Resource LimitationsMake sure you have sufficient free resources. FrontPage 97 requires a minimum of 16 megabytes (MB) of memory if you are running the Personal Web Server. If you are running other programs or services, they will be using resources that otherwise would be available to FrontPage. To free up resources, try either of the following:
Method 3: Errors in Video Subsystem or Registry ErrorsStart FrontPage Editor as a stand-alone program by double-clicking the Fpeditor.exe file in the \Program Files\Microsoft FrontPage\bin folder. Because FrontPage registers itself when you start it, it may be able to fix any registry errors related to it. If you still receive errors after starting FrontPage Editor, follow these steps.NOTES:
Method 4: Undo Registry Cleaning UtilitiesIf you used a utility to clean the Registry (remove obsolete registry keys), restart the registry cleaning program and restore the Registry to its previous state. If the program does not provide a feature to restore previous Registry entries, go to Method 5.Method 5: Absence of Required Registry KeysWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.Microsoft has received reports that some computers appear to be "losing" the Registry settings that FrontPage needs to run properly. Microsoft has not determined why some computers are losing these Registry settings while other computers are not. If You Are Using Windows 95: Back up your registry, and then follow these steps:
Back up the following registry keys:
HKEY_CLasses_Root
HKEY_Current_User
To back up these registry keys, follow these steps:
Method 6: Missing FrontPage Registry KeyWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.On some computers, FrontPage 97 Setup does not create the following registry key: [HKEY_CURRENT_USER\Software\Microsoft\FrontPage\Editor] "Auxiliary DLL Registered For"="2.0.2.1112" It you determine that this key is missing from the Registry, use the following steps to install it. Windows 95: After you back up your Registry, follow these steps:
Back up the following Registry keys:
HKEY_CLasses_Root
To back up these Registry keys, do the following:
HKEY_Current_User
Method 7: Mismatched OLE Components on Windows NTFrontPage 97 calls OLE32.dll and OLEAUT32.dll files when making the connection between FrontPage Explorer and FrontPage Editor. These files may make further calls to other elements of the OLE subsystem. In the event your installation of OLE has been improperly upgraded or has become mismatched, a full installation of the most recent Service Pack for Windows NT may solve the problem. If you have followed all of the previous steps without success, try installing the latest Windows NT Service Pack from the following Web site:http://www.microsoft.com/ntserver/default.asp
(http://www.microsoft.com/ntserver/default.asp)
NOTE: Follow the Service Pack Setup directions explicitly. Also, be sure to
quit any programs which may use OLE before you install the service pack.
If you still receive the errors described in the "Symptoms" section, you will need to reinstall Windows NT to a new folder. Method 8: Reinstall WindowsFor additional information about how to reinstall Windows 95, click the article number below to view the article in the Microsoft Knowledge Base:142096
(http://support.microsoft.com/kb/142096/EN-US/
)
How to Reinstall Windows 95 to a New Folder
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