Article ID: 178173 - Last Review: September 23, 2005 - Revision: 2.1 Enabling Access Control in Web Proxy May Return a Blank PageThis article was previously published under Q178173 On This PageSYMPTOMS
If you enable access control and defined a valid Microsoft Windows NT user
or group account in Proxy Server 2.0 installed over Internet Information
Server version 4.0 (IIS), the Web Proxy clients may fail to connect and
display one of the following error messages:
NOTE: The error message depends on the browser you use. Microsoft Internet Explorer version 4.0 and 4.01:
Nothing returned to browser (no error or blank page)
The requested header not found.
Document contains no data.
CAUSE
This issue is caused by a problem with the authentication settings in IIS
4.0 and the Web Proxy ISAPI filter.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Windows NT 4.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
152734
(http://support.microsoft.com/kb/152734/EN-US/
)
How to Obtain the Latest Windows NT 4.0 Service Pack
STATUS
Microsoft has confirmed this to be a problem in Microsoft Internet Information Server version 4.0.
WORKAROUND
Use one of the following methods:
Method 1Disable Access Control in Web Proxy Service by opening the Web Proxy Properties within the MMC and go to the Permissions tab. Clear the Enable Access Control check box.Method 2Disable Anonymous access for the default web site in IIS 4.0.NOTE: This will enable Proxy clients to connect to the Internet; however, it does not allow anonymous users to connect to the default web site if the server is also used for Internet publishing.
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