Article ID: 188106 - Last Review: January 23, 2007 - Revision: 2.1

"An error occurred while Windows was working with the Control Panel file ...\SYSTEM\JOY.CPL" error message when you double-click the Game Controllers tool in Control Panel in Windows 98 or in Windows 95

This article was previously published under Q188106
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:
http://support.microsoft.com/default.aspx/w98?sid=460 (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fdefault.aspx%2fw98%3fsid%3d460)

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SYMPTOMS

When you double-click the Game Controllers tool in Control Panel, you may experience one of the following symptoms:
  • The Game Controllers dialog box may open and then immediately close.
  • You may receive the following error message:
    An error occurred while Windows was working with the Control Panel file ...\SYSTEM\JOY.CPL

CAUSE

This behavior can occur if the Dinput.dll file is missing or damaged.

RESOLUTION

To resolve this issue, use the appropriate method:

Windows 95

  1. If it exists, rename the Dinput.dll file located in the Windows\System folder.

    For information about how to rename a file, click Start, click Help, click the Index tab, type renaming, and then double-click the "Renaming files" topic.
  2. Reinstall DirectX 6.0 or later.

    For information about how to obtain DirectX 6.0, please see the following article in the Microsoft Knowledge Base:
    ARTICLE-ID: 179113  (http://support.microsoft.com/kb/179113/EN-US/ )
    TITLE : How to Download and Install DirectX

Windows 98

  1. If it exists, rename the Dinput.dll file located in the Windows\System folder.

    For information about how to rename a file, click Start, click Help, click the Index tab, type renaming, and then double-click the "Renaming files" topic.
  2. Extract a new copy of the Dinput.dll file from your original Windows 98 CD-ROM into the Windows\System folder.

    For information about using the Extract tool, type extract at a command prompt, or see the following article in the Microsoft Knowledge Base:
    ARTICLE-ID: 129605  (http://support.microsoft.com/kb/129605/EN-US/ )
    TITLE : How to Extract Original Compressed Windows Files

APPLIES TO
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Keywords: 
kberrmsg kbprb KB188106
 

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