Help and Support
 

powered byLive Search

FP98: Early Versions of Web Publishing Wizard Damage Extensions

Article ID:194260
Last Review:October 3, 2001
Revision:1.0
This article was previously published under Q194260

For a Microsoft FrontPage 97 and earlier version of this article, see 159440 (http://support.microsoft.com/kb/159440/EN-US/).
On This Page

SYMPTOMS

If you use version 1.0 or 1.0a of the Microsoft Web Publishing Wizard to post files from a FrontPage Web to a FrontPage extended Web server, the FrontPage Server Extensions on the Web server may be damaged.

Back to the top

CAUSE

This problem occurs with Microsoft Web Publishing Wizard versions 1.0 and 1.0a. These versions of the wizard may overwrite the server extensions on the destination server.

Back to the top

RESOLUTION

If a FrontPage Web has been posted to a FrontPage Web server using a version of the Microsoft Web Publishing Wizard earlier than version 1.1, you must uninstall and then re-install the FrontPage Server Extensions on the server.

Once you have reinstalled the extensions on the damaged server, use either of the following methods to post a FrontPage Web to a FrontPage server.

Back to the top

Method 1: Use Microsoft Web Publishing Wizard Version 1.1

This version of the wizard includes a driver that will allow the Web Publishing Wizard to connect to and safely transfer data using the HTTP protocol.

Version 1.1 of the Web Publishing Wizard can be identified by checking the modification date and file size of the following files:
   File name:     Wpwiz.exe
   Modified date: Wednesday, November 12, 1996 5:28:27 PM
   File size:     10,114 KB

   File name:     Fpwpp.dll
   Modified date: Monday, October 07, 1996 7:38:42 AM
   Size:          106,496 KB
				

The unexpanded version of the 1.1 Microsoft Web Publishing Wizard is named Webpost.exe and it is version 4.71.0121.0.

Back to the top

Method 2: If You Must Use an Earlier Version of the Wizard

If you must use an earlier version of the Microsoft Web Publishing Wizard without FrontPage to transport files to a server with FrontPage Server Extensions, use the following guidelines:
Copy only individual files.
Do not transfer any file from a directory if the file name begins with the "_vti_" prefix.
After you publish the files, use the following steps:

1.From FrontPage Explorer, open the Web on the destination server.
2.On the Tools menu, click Recalculate Hyperlinks.

Back to the top

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.

Back to the top

MORE INFORMATION

FrontPage Server Extensions are created and compiled for specific Web servers on a particular operating system. The Microsoft Web Publishing Wizard is a stand-alone program that can post files to any Web server with which the client has either an FTP or a Windows file sharing network connection.

The Microsoft Web Publishing Wizard version 1.1 is a component of the FrontPage 98. When the Publishing Wizard is installed, FrontPage will start it automatically when you attempt to publish a FrontPage Web to a destination server that does not have the FrontPage Server Extensions installed.

The recommended way to publish any FrontPage Web is to click Publish FrontPage Web on the File menu in FrontPage Explorer. If you use FrontPage to publish to a Web server that does not have the FrontPage Server Extensions installed, FrontPage will automatically start the Microsoft Web Publishing Wizard (if it is installed) and pass it the list of files to post by creating a directory called "upload" (for example, c:\program files\Microsoft FrontPage\temp\upload). This directory contains only the files that should be posted (for example, you can specify to post only files that have been changed since the last time you posted the Web).

For more information about the Microsoft Web Publishing Wizard, see the Microsoft Web site at:
http://corporate.windowsupdate.microsoft.com/ (http://corporate.windowsupdate.microsoft.com/)

Back to the top


APPLIES TO
Microsoft FrontPage 98 Standard Edition

Back to the top

Keywords: 
kbbug kbpending KB194260

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.