Article ID: 196975 - Last Review: October 31, 2006 - Revision: 1.1 CRC Error Messages on Multiple-Processor ComputersThis article was previously published under Q196975 SYMPTOMS
When you use a remote access server to transfer data over a null modem
cable between a multiple-processor computer and a singe-processor
computer, you may receive cyclical redundancy check (CRC) or data overrun
error messages in Dial-Up Monitor.
CAUSE
The overruns were occurring because the internal buffers in the UART (FIFO's) filled up before the interrupt was serviced and data was lost on the RS-232 bus. Further debugging found that the serial interrupt is masked for longer than .087 ms by the IDE interrupts that were being serviced.
RESOLUTION
There are a couple of settings in the registry that will allow the interrupts to be serviced quicker, set RxFIFO to 1:
HKLM\System\CurrentControlSet\Services\Serial
By default DMA is not enabled on Windows NT. Once enabling DMA the problem was resolved. I was able to increase the baud rate to 115k and transfer over 100 meg of data with no errors. Enabling improves CPU utilization over standard PIO, increasing system usability while IDE operations are in
progress.
STATUS
Microsoft has confirmed this to be a bug in the Microsoft products listed
at the beginning of this article.
MORE INFORMATION
Using PCI bus master DMA, the CPU has to service only a single interrupt
that is generated when the IDE command completes. This is compared to
standard PIO, where the CPU has to service an interrupt from the device,
every time a block of data becomes available to the host. Performance
figures on a checked build showed approximately 20 to 30 percent CPU
utilization using DMA, versus approximately 90 to 100 percent utilization
during PIO transfers. Performance figures for DMA on a free build are even
better, showing single-digit percentages in some cases.
How to Obtain Dmacheck.exe for Windows NT
[winnt]
ID: Q191774 CREATED: 24-AUG-1998 MODIFIED: 24-AUG-1998
WinNT:4.0
For more information about downloading files from the Microsoft Download Center, please see the following article in the Microsoft Knowledge Base:
ARTICLE-ID: Q119591
TITLE : How to Obtain Microsoft Support Files from Online Services
The following motherboards have exhibited the behavior described in this
article:
| Article Translations
|

Back to the top
